您的位置:首页 > 其它

poj 1002 487-3279

2017-02-20 18:50 429 查看
Description
Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP.
Sometimes only part of the number is used to spell a word. When you get back to your hotel tonight you can order a pizza from Gino's by dialing 310-GINO. Another way to make a telephone number memorable is to group the digits in a memorable way. You could
order your pizza from Pizza Hut by calling their ``three tens'' number 3-10-10-10.

The standard form of a telephone number is seven decimal digits with a hyphen between the third and fourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows:

A, B, and C map to 2

D, E, and F map to 3

G, H, and I map to 4

J, K, and L map to 5

M, N, and O map to 6

P, R, and S map to 7

T, U, and V map to 8

W, X, and Y map to 9

There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary. The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010.

Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.)

Your company is compiling a directory of telephone numbers from local businesses. As part of the quality control process you want to check that no two (or more) businesses in the directory have the same telephone number.

Input
The input will consist of one case. The first line of the input specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers
in the directory, with each number alone on a line. Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters.

Output
Generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard form, followed by a space, followed by the number of times the telephone number
appears in the directory. Arrange the output lines by telephone number in ascending lexicographical order. If there are no duplicates in the input print the line:

No duplicates.

Sample Input
12
4873279
ITS-EASY
888-4567
3-10-10-10
888-GLOP
TUT-GLOP
967-11-11
310-GINO
F101010
888-1200
-4-8-7-3-2-7-9-
487-3279

Sample Output
310-1010 2
487-3279 4
888-4567 3


题意很简单,就是处理输入的字符串,根据规则将他们转化为正常的电话号码,最后输出数目大于1的号码,空格之后加上该号码出现的次数
这里可以使用map,利用键值来储存,对于不需要认识的字符比如-和QZ,就可以直接不去处理,还有就是对字符串和字符数组的利用,在三个
字符之后自己加上一个-就可以,看过别的有些博客,有些表示这道题的测试数据很变态,会有很多个-,但是只要对它不去处理,最后自己加上-,
就可以解决这个问题,在提交的时候,出现编译错误,之后发现是头文件用的是cstring而不是string
#include<iostream>
#include<cstring>
#include<map>
#include<cstdio>
#include<string>
using namespace std;
char str[100];
string re;
int sum;
map<string,int> mp;
map<string,int>::iterator it;

int main()
{
int times;
cin>>times;
while(times--)
{
scanf("%s",str);
re = "";
sum = 0;
int len = strlen(str);
for(int i = 0;i<len;i++)
{
if(str[i]>='0'&&str[i]<='9')
{
re+=str[i];
sum++;
if(sum==3)
re+='-';
}
else if(str[i]=='A'||str[i]=='B'||str[i]=='C')
{
re+='2';
sum++;
if(sum==3)
re+='-';
}
else if(str[i]=='D'||str[i]=='E'||str[i]=='F')
{
re+='3';
sum++;
if(sum==3)
re+='-';
}
else if(str[i]=='G'||str[i]=='H'||str[i]=='I')
{
re+='4';
sum++;
if(sum==3)
re+='-';
}
else if(str[i]=='J'||str[i]=='K'||str[i]=='L')
{
re+='5';
sum++;
if(sum==3)
re+='-';
}
else if(str[i]=='M'||str[i]=='N'||str[i]=='O')
{
re+='6';
sum++;
if(sum==3)
re+='-';
}
else if(str[i]=='P'||str[i]=='R'||str[i]=='S')
{
re+='7';
sum++;
if(sum==3)
re+='-';
}
else if(str[i]=='T'||str[i]=='U'||str[i]=='V')
{
re+='8';
sum++;
if(sum==3)
re+='-';
}
else if(str[i]=='W'||str[i]=='X'||str[i]=='Y')
{
re+='9';
sum++;
if(sum==3)
re+='-';
}
else if(sum==7)
break;
}
mp[re]++;
}
int cnt = 0;
for(it = mp.begin();it!=mp.end();it++)
{
if((*it).second>1)
{
cout<<(*it).first<<" "<<(*it).second<<endl;
cnt++;
}
}
if(!cnt)
cout<<"No duplicates."<<endl;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm poj map