您的位置:首页 > 其它

1002. A+B for Polynomials (25)

2017-02-20 09:14 260 查看
This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where
K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

3 2 1.5 1 2.9 0 3.2

需要注意的是输出格式,输出要用%.1lf,非%g

#include <stdio.h>
#include <stdlib.h>

int main()
{
double a[1010], b[1010];
int k1 = 0, k2 = 0;
int i = 0;// 下标
for (i; i < 1010; i++) {
a[i] = b[i] = 0;
}
scanf("%d", &k1);
while (k1--)
{
scanf("%d", &i);
scanf("%lf", &a[i]);
}
scanf("%d", &k2);
while (k2--)
{
scanf("%d", &i);
scanf("%lf", &b[i]);
}
k1 = 0;
for (i = 0; i < 1010; i++) {
a[i] += b[i];
if (a[i] != 0)
k1++;
}
printf("%d", k1);
for (i = 1009; i >= 0; i--)
if (a[i] != 0)
printf(" %d %.1lf", i, a[i]);
printf("\n");
//system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  PAT甲级