您的位置:首页 > 其它

ZOJ 3329 One Person Game

2017-02-19 17:37 197 查看
There is a very simple and interesting one-person game. You have 3 dice, namely Die1Die2 and Die3Die1 has K1 faces. Die2 has K2 faces. Die3 has K3 faces.
All the dice are fair dice, so the probability of rolling each value, 1 to K1, K2, K3 is exactly 1 / K1, 1 / K2 and 1 / K3. You have a counter,
and the game is played as follow:

Set the counter to 0 at first.
Roll the 3 dice simultaneously. If the up-facing number of Die1 is a, the up-facing number of Die2 is b and the up-facing number of Die3 is c, set the counter to 0. Otherwise,
add the counter by the total value of the 3 up-facing numbers.
If the counter's number is still not greater than n, go to step 2. Otherwise the game is ended.
Calculate the expectation of the number of times that you cast dice before the end of the game.

Input

There are multiple test cases. The first line of input is an integer T (0 < T <= 300) indicating the number of test cases. Then T test cases follow. Each test case is a line contains 7 non-negative integers n, K1, K2, K3, a, b, c (0
<= n <= 500, 1 < K1, K2, K3 <= 6, 1 <= a <= K1, 1 <= b <= K2, 1 <= c <= K3).

Output

For each test case, output the answer in a single line. A relative error of 1e-8 will be accepted.

Sample Input

2
0 2 2 2 1 1 1
0 6 6 6 1 1 1


Sample Output

1.142857142857143
1.004651162790698
概率dp,倒着递推式子
#include<map>
#include<cmath>
#include<queue>
#include<vector>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define ms(x,y) memset(x,y,sizeof(x))
#define rep(i,j,k) for(int i=j;i<=k;i++)
#define per(i,j,k) for(int i=j;i>=k;i--)
#define loop(i,j,k) for (int i=j;i!=-1;i=k[i])
#define inone(x) scanf("%d",&x)
#define intwo(x,y) scanf("%d%d",&x,&y)
#define inthr(x,y,z) scanf("%d%d%d",&x,&y,&z)
typedef long long LL;
const int low(int x) { return x&-x; }
const int INF = 0x7FFFFFFF;
const int mod = 1e9 + 7;
const int N = 1e3 + 10;
const int M = 1e5 + 10;
int T, n, a, b, c, k1, k2, k3, K;
double dp
, p
, A
, B
;

/*
dp[i]=∑(dp[i+k]+1)*pk+p0*(dp[0]+1);
dp[i]=∑dp[i+k]*pk+1+p0*dp[0];
*/

int main()
{
for (inone(T); T--;)
{
inone(n); inthr(k1, k2, k3); inthr(a, b, c);
ms(p, 0);
K = k1 * k2 * k3;
rep(i, 1, k1) rep(j, 1, k2) rep(k, 1, k3)
p[i + j + k] += (i != a || j != b || k != c) * 1.0 / K;
per(i, n, 0)
{
A[i] = 1; B[i] = 1.0 / K;
rep(j, 3, K)
{
if (i + j > n) continue;
A[i] += A[i + j] * p[j];
B[i] += B[i + j] * p[j];
}
}
printf("%.15lf\n", A[0] / (1 - B[0]));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: