您的位置:首页 > 其它

Treasure the new start, freshmen!

2017-02-19 15:45 417 查看
background:

A new semester comes , and the HDU also meets its 50th birthday. No matter what's your major, the only thing I want to tell you is:"Treasure the college life and seize the time." Most people thought that the college life should be colorful, less presure.But
in actual, the college life is also busy and rough. If you want to master the knowledge learned from the book, a great deal of leisure time should be spend on individual study and practise, especially on the latter one. I think the every one of you should
take the learning attitude just as you have in senior school.

"No pain, No Gain", HDU also has scholarship, who can win it? That's mainly rely on the GPA(grade-point average) of the student had got. Now, I gonna tell you the rule, and your task is to program to caculate the GPA.

If there are K(K > 0) courses, the i-th course has the credit Ci, your score Si, then the result GPA is

GPA = (C1 * S1 + C2 * S2 +……+Ci * Si……) / (C1 + C2 + ……+ Ci……) (1 <= i <= K, Ci != 0)

If there is a 0 <= Si < 60, The GPA is always not existed.
InputThe first number N indicate that there are N test cases(N <= 50). In each case, there is a number K (the total courses number), then K lines followed, each line would obey the format: Course-Name (Length <= 30) , Credits(<=
10), Score(<= 100).

Notice: There is no blank in the Course Name. All the Inputs are legalOutputOutput the GPA of each case as discribed above, if the GPA is not existed, ouput:"Sorry!", else just output the GPA value which is rounded to the 2 digits after the decimal point. There is a blank line between two test cases.

Sample Input
2
3
Algorithm 3 97
DataStruct 3 90
softwareProject 4 85
2
Database 4 59
English 4 81

Sample Output90.10
sorry

题解:这道水题很简单,值得注意的是每两组数据之间要有两个空格。最后一个数据没有空格。我的处理办法是在最后加了一个 if(n) 来判断。

我的代码:

#include<iostream>

#include<stdio.h>

#include<algorithm>

#include<cmath>

#include<iomanip>

#include<string.h>

using namespace std;

int main( )

{

    int n, num;

    cin>> n;

    while (n--)

    {

            cin >> num;

            char s[16000];

            memset (s, '0', sizeof(s));

            double a[1000] = {0}, b[1000] = {0},  r = 0, c = 0;

            int i, flag=0;

                for (i = 1; i <= num; i++)

                cin >> s >> a[i] >> b[i];

            for (i = 1; i <= num; i++)

            {

                r = a[i] * b[i] + r;

                c = c + a[i];

            }

            r = r / c;

            for (i = 1; i <= num; i++)

            {

                if(b[i] < 60)

       
4000
             flag = 1;

            }

            if (flag == 1)

                cout << "Sorry!" << endl;

            else

            printf("%.2lf\n", r);

            if (n)

                cout <<endl;

    }

    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: