您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之链表七:单链表中重复元素的删除

2017-02-19 09:36 239 查看

                                                                数据结构实验之链表七:单链表中重复元素的删除

Time Limit: 1000MS
Memory Limit: 65536KB
[align=center]SubmitStatistic[/align]

Problem Description

按照数据输入的相反顺序(逆位序)建立一个单链表,并将单链表中重复的元素删除(值相同的元素只保留最后输入的一个)。

Input

第一行输入元素个数 n (1 <= n <= 15);

第二行输入 n 个整数,保证在 int 范围内。

Output

第一行输出初始链表元素个数;

第二行输出按照逆位序所建立的初始链表;

第三行输出删除重复元素后的单链表元素个数;

第四行输出删除重复元素后的单链表。

Example Input

10
21 30 14 55 32 63 11 30 55 30


Example Output

10
30 55 30 11 63 32 55 14 30 21
7
30 55 11 63 32 14 21


Hint

Author

不得使用数组!  

#include <stdio.h>

#include <stdlib.h>

struct node

{

    int data;

    struct node *next;

};

int n;//定义全局变量,方便。

struct node *creat(struct node *head,int n)

{

    int i;

    struct node *q;

    for(i=0; i<n; i++)

    {

        q=(struct node *)malloc(sizeof(struct node ));

        scanf("%d",&q->data);

        q->next=head->next;

        head->next=q;

    }

    return head;

};

void show(struct node *head)

{

    struct node *q;

    q=head->next;

    while(q->next!=NULL)

    {

        printf("%d ",q->data);

        q=q->next;

    }

    printf("%d\n",q->data);

}

struct node *dele(struct node *head)

{

    struct node *q,*p,*d;

    q=head->next;

    p=q;

    while(q->next!=NULL)  ///1.到最后一个元素.  2.访问最后一个数后就直接跳出

    {

        while(p->next!=NULL)  ///1.需要遍历整个链表时

        {

            if(p->next->data==q->data) ///q和p不再有删除的关系

            {

                d=p->next;     /// 有删除的情况才记下d

                p->next=d->next;

                free(d);

                n--;///   直接用n--表示最后的数

            }

            else p=p->next;

        }

        if(q->next!=NULL)

        {

            q=q->next;   ///访问下一个元素

            p=q;         ///p也跟着往后移

        }

    }

    return head;

};

int main()

{

    struct node *head;

    head=(struct node *)malloc(sizeof(struct node ));

    head->next=NULL;

    scanf("%d",&n);

    head=creat(head,n);

    printf("%d\n",n);

    show(head);

    head=dele(head);

    printf("%d\n",n);

    show(head);

    return 0;

}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: