您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之栈一:进制转换

2017-02-17 20:55 357 查看
Problem Description

输入一个十进制非负整数,将其转换成对应的 R (2 <= R <= 9) 进制数,并输出。

Input

第一行输入需要转换的十进制非负整数;

第二行输入 R。

Output

输出转换所得的 R 进制数。

Example Input

1279

8

Example Output

2377

n=0的时候单独判断一下

#include <stdio.h>
#include <string.h>
int main()
{
int n,r,top=-1;
int a[100000];
scanf("%d%d",&n,&r);
if(n==0)
printf("0");

while(n)
{
a[++top]=n%r;
n/=r;
}
int i;
for(i=top;i>=0;i--)
{
printf("%d",a[i]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: