您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之栈一:进制转换

2017-02-17 15:19 316 查看
 

 要注意对于0的处理,第一次就卡到了这个0上才没有ac


Problem Description

输入一个十进制非负整数,将其转换成对应的 R (2 <= R <= 9) 进制数,并输出。


Input

第一行输入需要转换的十进制非负整数;

第二行输入 R。


Output

输出转换所得的 R 进制数。


Example Input

1279
8



Example Output

2377


#include<iostream>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<stack>
using namespace std;

int main()
{
int n,m;
stack <int >s ;
int temp;
scanf("%d %d",&n,&m);
if(n==0)
printf("0");
else
{
while(n>0)
{
temp=n%m;
s.push(temp);
n=n/m;
}
}
while(!s.empty())
{
printf("%d",s.top());
s.pop();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: