您的位置:首页 > 其它

hdu 1907(反尼姆博弈)

2017-02-17 12:50 337 查看

John

[b]Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)

Total Submission(s): 4617    Accepted Submission(s): 2660
[/b]

Problem Description
Little John is playing very funny game with his younger brother. There is one big box filled with M&Ms of different colors. At first John has to eat several M&Ms of the same color. Then his opponent has to make a turn. And so on. Please
note that each player has to eat at least one M&M during his turn. If John (or his brother) will eat the last M&M from the box he will be considered as a looser and he will have to buy a new candy box.

Both of players are using optimal game strategy. John starts first always. You will be given information about M&Ms and your task is to determine a winner of such a beautiful game.

Input
The first line of input will contain a single integer T – the number of test cases. Next T pairs of lines will describe tests in a following format. The first line of each test will contain an integer N – the amount of different M&M
colors in a box. Next line will contain N integers Ai, separated by spaces – amount of M&Ms of i-th color.

Constraints:

1 <= T <= 474,

1 <= N <= 47,

1 <= Ai <= 4747

Output
Output T lines each of them containing information about game winner. Print “John” if John will win the game or “Brother” in other case.

Sample Input

2
3
3 5 1
1
1

Sample Output

John
Brother

 反尼姆博弈结论:n堆物品,全部异或结果为ans,统计富裕堆的个数为c;
先手胜有两种情况:
第一,ans=0且富裕堆个数不大于1;
第二,ans!=0且存在富裕堆;
知乎大牛详述
#include<cstdio>
int main()
{
int t,m,n;
scanf("%d",&t);
while(t--)
{
int ans=0,c=0;
scanf("%d",&n);
for(int i=0;i<n;i++)
{
scanf("%d",&m);
if(m>1) c++;//统计富裕堆个数
ans^=m;
}
if((!ans && c<2) || (ans && c)) printf("John\n");//先手胜
else printf("Brother\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: