您的位置:首页 > 其它

1002. A+B for Polynomials (25)

2017-02-16 18:38 302 查看

1002. A+B for Polynomials (25)

This time, you are supposed to find A+B where A and B are two polynomials.

Input:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < … < N2 < N1 <=1000.

Output:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input

2 1 2.4 0 3.2

2 2 1.5 1 0.5

Sample Output

3 2 1.5 1 2.9 0 3.2

#include<stdio.h>
int main()
{
int i,j, a,z,k=0;
double x, sum[2005] = {0};
for (j = 0; j < 2; j++)
{
scanf("%d", &a);
for (i = 0; i < a; i++)
{
scanf("%d %lf", &z,&x);
if (sum[z] == 0) k++;
sum[z] =sum[z]+ x;
if (sum[z] == 0) k--;
}
}
printf("%d", k);
for (i = 2004; i >= 0;i--)
{
if (sum[i] != 0)
{
printf(" %d %.1lf", i, sum[i]);
}
}
return 0;
}


这点很关键 楼主粗心啦 : (

if (sum[z] == 0) k--;
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  PAT 1002