您的位置:首页 > 其它

hdu1159(dp)最长公共子序列

2017-02-16 18:21 387 查看

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 36932    Accepted Submission(s): 16896


[align=left]Problem Description[/align]A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. 
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. 
 
[align=left]Sample Input[/align]
abcfbc abfcab
programming contest
abcd mnp 
[align=left]Sample Output[/align]
4
2

[align=left]Source[/align]Southeastern Europe 2003 
[align=left]Recommend[/align]Ignatius   |   We have carefully selected several similar problems for you:  1069 1421 1203 1

就用二维数组记录,很经典的一道题,麻省理工那个算法导论课里面的例子,画个二维数组就知道啦
#include<iostream>
using namespace std;
int dp[101][101];
int main()
{
int i,j,k,l,n,m,p,t;
while(scanf("%d%d%d%d",&n,&p,&m,&t)!=EOF)
{
memset(dp,0,sizeof(dp));
dp[0][p]=1;
for(i=1;i<=m;i++)
{
for(j=1;j<=n;j++)
{
if(dp[i-1][j-1]!=0 || dp[i-1][j+1]!=0)
{
dp[i][j]=dp[i-1][j-1]+dp[i-1][j+1];
}
}
}
cout<<dp[m][t]<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: