您的位置:首页 > 其它

hdu2473(并查集的删除)

2017-02-16 16:01 387 查看

Junk-Mail Filter

Time Limit: 15000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9266    Accepted Submission(s): 2933


[align=left]Problem Description[/align]Recognizing junk mails is a tough task. The method used here consists of two steps:
1) Extract the common characteristics from the incoming email.
2) Use a filter matching the set of common characteristics extracted to determine whether the email is a spam.

We want to extract the set of common characteristics from the N sample junk emails available at the moment, and thus having a handy data-analyzing tool would be helpful. The tool should support the following kinds of operations:

a) “M X Y”, meaning that we think that the characteristics of spam X and Y are the same. Note that the relationship defined here is transitive, so
relationships (other than the one between X and Y) need to be created if they are not present at the moment.

b) “S X”, meaning that we think spam X had been misidentified. Your tool should remove all relationships that spam X has when this command is received; after that, spam X will become an isolated node in the relationship graph.

Initially no relationships exist between any pair of the junk emails, so the number of distinct characteristics at that time is N.
Please help us keep track of any necessary information to solve our problem. 
[align=left]Input[/align]There are multiple test cases in the input file.
Each test case starts with two integers, N and M (1 ≤ N ≤ 105 , 1 ≤ M ≤ 106), the number of email samples and the number of operations. M lines follow, each line is one of the two formats described above.
Two successive test cases are separated by a blank line. A case with N = 0 and M = 0 indicates the end of the input file, and should not be processed by your program. 
[align=left]Output[/align]For each test case, please print a single integer, the number of distinct common characteristics, to the console. Follow the format as indicated in the sample below. 
[align=left]Sample Input[/align]
5 6
M 0 1
M 1 2
M 1 3
S 1
M 1 2
S 3

3 1
M 1 2

0 0 
[align=left]Sample Output[/align]
Case #1: 3
Case #2: 2        今天第五道并查集 打算把相关操作都学了 这题是删减,删减操作不难,你删除的那个点,其后跟着的都要作废掉,那咋办,想了一种土方法,就是把这个点后面的枝叶接到一个不在本题范围的点上,百度了一下这种方法叫找虚根。。长见识了,开始是用set 好方便,以后多用哈哈哈哈,不过这题多用了一个vis数组,内存占了一大堆。。vis数组记录的其实是1,2,3,4.......跟一个i循环差不多,区别就在特定的数,比如那个数是虚根的话就直接被引到比n大的地方了,神奇的办法,写下这些方便以后回来复习复习!
#include<iostream>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
#include<set>
using namespace std;
int par[100005];
int vis[100005];//记录节点
int flag;
set<int> S;
void init(int x) {
for (int i = 0; i<x; i++) {
vis[i] = i;
}
}
int find(int x) {
if (par[x] == x) return x;
else
return par[x]=find(par[x]);
}
void unite(int x, int y) {
int a = find(x);
int b = find(y);
if (a == b){
return ;
}
else {
par[a] = b;
}
return ;
}
int main(){
int n,m;
int sase = 0;
while(scanf("%d%d",&n,&m)){
if(n == 0 && m == 0) break;
sase++;
int cnt = n;
for(int i = 0;i < 100005;i++) par[i] = i;
for(int i = 0;i < n;i++) vis[i] = i;
while(m--){
char s[3];
int a,b;
scanf("%s",s);
if(s[0] == 'M'){
scanf("%d%d",&a,&b);
unite(vis[a],vis[b]);
}
else{
scanf("%d",&a);
vis[a] = cnt++;
}
}
S.clear();
for(int i = 0;i < n;i++){
S.insert(find(vis[i]));
}
printf("Case #%d: %d\n",sase,S.size());
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: