您的位置:首页 > 产品设计 > UI/UE

poj 3146 Interesting Yang Hui Triangle (Lucas定理)

2017-02-14 15:29 465 查看
Interesting Yang Hui Triangle

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 1772 Accepted: 875
Description

Harry is a Junior middle student. He is very interested in the story told by his mathematics teacher about the Yang Hui triangle in the class yesterday. After class he wrote the following numbers to show the triangle our ancestor studied.

 1 
 1 1 
 1 2 1 
 1 3 3 1 
 1 4 6 4 1 
 1 5 10 10 5 1 
 1 6 15 20 15 6 1 
1 7 21 35 35 21 7 1
 …… 
He found many interesting things in the above triangle. It is symmetrical, and the first and the last numbers on each line is 1; there are exactly i numbers on the line i.

Then Harry studied the elements on every line deeply. Of course, his study is comprehensive.

Now he wanted to count the number of elements which are the multiple of 3 on each line. He found that the numbers of elements which are the multiple of 3 on line 2, 3, 4, 5, 6, 7, … are 0, 0, 2, 1, 0, 4, … So the numbers of elements which are not divided
by 3 are 2, 3, 2, 4, 6, 3, …, respectively. But he also found that it was not an easy job to do so with the number of lines increasing. Furthermore, he is not satisfied with the research on the numbers divided only by 3. So he asked you, an erudite expert,
to offer him help. Your kind help would be highly appreciated by him.

Since the result may be very large and rather difficult to compute, you only need to tell Harry the last four digits of the result.

Input

There are multiple test cases in the input file. Each test case contains two numbers P and N, (P < 1000, N ≤ 109), where P is a prime number and N is a positive decimal integer.

P = 0, N = 0 indicates the end of input file and should not be processed by your program.

Output

For each test case, output the last four digits of the number of elements on the N + 1 line on Yang Hui Triangle which can not be divided by P in the format as indicated in the sample output.

Sample Input
3 4
3 48
0 0

Sample Output
Case 1: 0004
Case 2: 0012

Source

Shanghai 2006
[Submit]   [Go Back]   [Status]  
[Discuss]

题目大意:求c
[0..n]中有多少数不能被p整除,其中p为质数,c表示组合数。

题解:Lucas定理

对于c(n,m)我们可以将n,m都分解成p进制数

n=a[k]a[k-1]...a[0]

m=b[k]b[k-1]...b[0]



如果最后的结果不能被p整除,那么一定不存在c[ni][mi]==0

那么在什么情况下c[ni][mi]等于0呢?当且仅当mi>ni的时候。因为p是质数,ni<p,所以0..ni中的所以数与p互质,那么c[ni][mi]也一定与p互质。

因为n已知,那么a数组就是已知的,bi的取值只有ai+1种,最后用乘法原理乘起来即可。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
#define N 1003
#define LL long long
using namespace std;
int n,p;
int c

,a

,x
,y
,mi
,cnt,vis
,sum;
int lucas(int n,int m)
{
if (m==0) return 1;
return c[n%p][m%p]*lucas(n/p,m/p)%p;
}
int main()
{
freopen("a.in","r",stdin);
//freopen("my.out","w",stdout);
int T=0;
while (true) {
++T;
scanf("%d%d",&p,&n);
if (!p&&!n) break;
printf("Case %d: ",T);
memset(c,0,sizeof(c));
c[1][1]=1;
c[2][1]=1; c[2][2]=1;
for (int i=3;i<=p;i++)
for (int j=1;j<=i;j++) {
c[i][j]=(c[i-1][j-1]+c[i-1][j])%p;
if (c[i][j]==0) a[i][++a[i][0]]=j;
}
int k=n;  cnt=-1;  int sum=1;
while (k) {
x[++cnt]=k%p;
sum*=(x[cnt]+1); sum%=10000;
k/=p;
}
if (sum/1000==0) printf("0");
if (sum/100==0) printf("0");
if (sum/10==0) printf("0");
printf("%d\n",sum);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: