您的位置:首页 > 其它

POJ3006_Dirichlet's Theorem on Arithmetic Progressions_筛法求素数表

2017-02-14 09:30 337 查看
Dirichlet's Theorem on Arithmetic Progressions

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 18557 Accepted: 9316
Description

If a and d are relatively prime positive integers, the arithmetic sequence beginning with a and increasing by d, i.e., a, a + d, a + 2d, a + 3d, a +
4d, ..., contains infinitely many prime numbers. This fact is known as Dirichlet's Theorem on Arithmetic Progressions, which had been conjectured by Johann Carl Friedrich Gauss (1777 - 1855) and was proved by Johann Peter Gustav Lejeune Dirichlet
(1805 - 1859) in 1837.

For example, the arithmetic sequence beginning with 2 and increasing by 3, i.e.,

2, 5, 8, 11, 14, 17, 20, 23, 26, 29, 32, 35, 38, 41, 44, 47, 50, 53, 56, 59, 62, 65, 68, 71, 74, 77, 80, 83, 86, 89, 92, 95, 98, ... ,

contains infinitely many prime numbers

2, 5, 11, 17, 23, 29, 41, 47, 53, 59, 71, 83, 89, ... .

Your mission, should you decide to accept it, is to write a program to find the nth prime number in this arithmetic sequence for given positive integers a, d, and n.

Input

The input is a sequence of datasets. A dataset is a line containing three positive integers a, d, and n separated by a space. a and d are relatively prime. You may assume a <= 9307, d <= 346,
and n <= 210.

The end of the input is indicated by a line containing three zeros separated by a space. It is not a dataset.

Output

The output should be composed of as many lines as the number of the input datasets. Each line should contain a single integer and should never contain extra characters.

The output integer corresponding to a dataset a, d, n should be the nth prime number among those contained in the arithmetic sequence beginning with a and increasing by d.

FYI, it is known that the result is always less than 106 (one million) under this input condition.

Sample Input
367 186 151
179 10 203
271 37 39
103 230 1
27 104 185
253 50 85
1 1 1
9075 337 210
307 24 79
331 221 177
259 170 40
269 58 102
0 0 0

Sample Output
92809
6709
12037
103
93523
14503
2
899429
5107
412717
22699
25673


大致题意:

输入的每个样例有三个数字a,b,n。要求出以a为首项,b为公差的等差数列中的第n个素数。

大体思路:

首先用筛法打出素数表,然后检查 (素数-a)%b是否为0即可。

int prime[1000000];

void Prime()
{
for(int i=2;i<=Max;i++)
{
if(!prime[i]) prime[++prime[0]]=i;
for(int j=1;j<=prime[0]&&i*prime[j]<=Max;j++)
{
prime[i*prime[j]]=1;
if(!(i%prime[j])) break;
}
}
}

#include<cstdio>
#define Max 1000000

int prime[1000000];

void Prime()
{
for(int i=2;i<=Max;i++)
{
if(!prime[i]) prime[++prime[0]]=i;
for(int j=1;j<=prime[0]&&i*prime[j]<=Max;j++)
{
prime[i*prime[j
b55d
]]=1;
if(!(i%prime[j])) break;
}
}
}

int main()
{
//freopen("in.txt","r",stdin);

Prime();

int a,d,n,i,cnt;

while(scanf("%d %d %d",&a,&d,&n)&&n!=0)
{
for(i=1;prime[i]<a;i++);
for(cnt=0;cnt<n;i++)
{
if(!((prime[i]-a)%d)) cnt++;
}
printf("%d\n",prime[i-1]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: