您的位置:首页 > 其它

算典03_例题_06_Uva-1584

2017-02-13 15:51 453 查看

原题

Circular Sequence



Some DNA sequences exist in circular forms as in the following figure, which shows a circular sequence “CGAGTCAGCT”, that is, the last symbol “T” in “CGAGTCAGCT” is connected to the first symbol “C”. We always read a circular sequence in the clockwise direction. Since it is not easy to store a circular sequence in a computer as it is, we decided to store it as a linear sequence. However, there can be many linear sequences that are obtained from a circular sequence by cutting any place of the circular sequence. Hence, we also decided to store the linear sequence that is lexicographically smallest among all linear sequences that can be obtained from a circular sequence. Your task is to find the lexicographically smallest sequence from a given circular sequence. For the example in the figure, the lexicographically smallest sequence is “AGCTCGAGTC”. If there are two or more linear sequences that are lexicographically smallest, you are to find any one of them (in fact, they are the same).

Input

The input consists of T test cases. The number of test cases T is given on the first line of the input

file. Each test case takes one line containing a circular sequence that is written as an arbitrary linear

sequence. Since the circular sequences are DNA sequences, only four symbols, ‘A’, ‘C’, ‘G’ and ‘T’, are

allowed. Each sequence has length at least 2 and at most 100.

Output

Print exactly one line for each test case. The line is to contain the lexicographically smallest sequence

for the test case.

Sample Input

2

CGAGTCAGCT

CTCC

Sample Output

AGCTCGAGTC

CCCT

题解

求一个环状数组最小的字典序财展开数组

环状可以对长度取模转换为一般的数组

剩下的就和一般的找最小值一样处理

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
const int maxn = 1e2 + 5;
#define met(a,b) memset(a, b, sizeof(a));

char s[maxn];
int len;

int solve(){
int ans = 0;
for(int i = 1; i < len; ++i){
for(int j = 0; j < len; ++j){
if(s[(ans+j)%len] < s[(i+j)%len])break;
if(s[(ans+j)%len] > s[(i+j)%len]){
ans = i;
break;
}
}
}
return ans;
}

int main(){
int t; cin>>t;
while(t--){
scanf("%s", s);
len = strlen(s);

int ans = solve();
for(int i = 0; i < len; ++i){
printf("%c", s[(ans+i)%len]);
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: