您的位置:首页 > 其它

九度OJ-1154:Jungle Roads

2017-02-12 16:26 323 查看
  依然是最小生成树问题,使用并查集+kruskal实现。不赘述。

题目描述:

The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The
Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads,
even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through
I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems.
输入:

    The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the
alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this
village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms
for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village
will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above.
输出:

    The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute
time limit.
样例输入:
9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0

样例输出:
216
30

来源:2010年北京大学计算机研究生机试真题答疑:解题遇到问题?分享解题心得?讨论本题请访问:http://t.jobdu.com/thread-7877-1-1.html
#include <iostream>
#include <vector>
#include <algorithm>
#define MAXSIZE 1000
using namespace std;
struct Edge{
int start,end;
int weight;
Edge(){
}
Edge(int start,int end,int weight){
this->start=start;
this->end=end;
this->weight=weight;
}
bool operator<(const Edge &e)const{
return weight<e.weight;
}
};
bool cmp(Edge a,Edge b){
return a.weight<b.weight;
}

struct Set{ //UnionFindSet 从0开始
int root[MAXSIZE];
int setSize;
vector<Edge> edge;
int initSet(int setSize){
this->setSize=setSize;
edge.clear();
for (int i=0;i<setSize;i++){
root[i]=-1;
}
}
int findRoot(int x){//reduce deep
if (root[x]==-1)
return x;
else
return root[x]=findRoot(root[x]);
}
int unionSet(int x,int y){
int xroot=findRoot(x);
int yroot=findRoot(y);
if(xroot!=yroot){//if x&y are not in the same set 那么说明其中一个还是初态,一次都没有并过
root[xroot]=yroot; //merge xset into yset
return yroot;
}
return -1;
}
void print(){
cout<<endl;
}

};
int main(){
int n,t;
int x,y;
int weight,totalWeight;
char tempc;
Set set;
while (cin>>n,n){
//initiate
set.initSet(n);
totalWeight=0;
//input&create the edge list
for (int i=0;i<n-1;i++){
cin>>tempc>>t;
x=tempc-'A';
for (int j=0;j<t;j++){
cin>>tempc>>weight;
y=tempc-'A';
set.edge.push_back(Edge(x,y,weight));
}
}
//sort
sort(&set.edge[0],&set.edge[0]+set.edge.size());
//kruskal
for (int i=0;i<set.edge.size();i++){
if (set.unionSet(set.edge[i].start,set.edge[i].end)!=-1){//if merge the two sets
totalWeight+=set.edge[i].weight;
}
}
//output
cout<<totalWeight<<endl;
}
return true;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息