您的位置:首页 > 其它

uva 10935 Throwing cards away I

2017-02-12 15:34 1801 查看
原题:

Given is an ordered deck of n cards numbered 1 to n with card 1 at the top and card n at the bottom. The following operation is performed as long as there are at least two cards in the deck: Throw away the top card and move the card that is now on the top of the

deck to the bottom of the deck. Your task is to find the sequence of discarded cards and the last, remaining card.

Input

Each line of input (except the last) contains a number n ≤ 50. The last line contains ‘0’ and this line should not be processed.

Output

For each number from the input produce two lines of output. The first line presents the sequence of discarded cards, the second line reports the last remaining card. No line will have leading or trailing spaces. See the sample for the expected format.

Sample Input

7

19

10

6

0

Sample Output

Discarded cards: 1, 3, 5, 7, 4, 2

Remaining card: 6

Discarded cards: 1, 3, 5, 7, 9, 11, 13, 15, 17, 19, 4, 8, 12, 16, 2, 10, 18, 14

Remaining card: 6

Discarded cards: 1, 3, 5, 7, 9, 2, 6, 10, 8

Remaining card: 4

Discarded cards: 1, 3, 5, 2, 6

Remaining card: 4

中文:

给你n个牌摞成一堆,每次把第一张扔掉,然后再把第一张放到最后。最后输出扔掉的牌,再输出最后剩下的牌。

#include <bits/stdc++.h>
using namespace std;
int n;
vector<int> tmp;
int main()
{
ios::sync_with_stdio(false);
for(int i=1;i<=50;i++)
tmp.push_back(i);
while(cin>>n,n)
{
deque<int> di(tmp.begin(),tmp.begin()+n);
cout<<"Discarded cards:";
while(di.size()>=2)
{
if(di.size()==2)
cout<<" "<<di.front();
else
cout<<" "<<di.front()<<",";
di.pop_front();
di.push_back(di.front());
di.pop_front();
}
cout<<endl;
cout<<"Remaining card: "<< di.front()<<endl;
}
return 0;
}


思路:

超级简单题,凑个数。用deque即可
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: