您的位置:首页 > 其它

区间[A,B]与N互素的元素个数 [容斥][Eratosthenes筛法]

2017-02-11 23:30 417 查看

Problem Description

Given a number N, you are asked to count the number of integers between A and B inclusive which are relatively prime to N.

Two integers are said to be co-prime or relatively prime if they have no common positive divisors other than 1 or, equivalently, if their greatest common divisor is 1. The number 1 is relatively prime to every integer.

Input

The first line on input contains T (0 < T <= 100) the number of test cases, each of the next T lines contains three integers A, B, N where (1 <= A <= B <= 1015) and (1 <=N <= 109).

Output

For each test case, print the number of integers between A and B inclusive which are relatively prime to N. Follow the output format below.

Sample Input

2

1 10 2

3 15 5

Sample Output

Case #1: 5

Case #2: 10

Hint

In the first test case, the five integers in range [1,10] which are relatively prime to 2 are {1,3,5,7,9}.

解题报告

LL ans用成int ,debug半天没看出了,一直wa,心累。

求区间[A,B]与N互素的元素个数,这是一个经典的容斥问题。

公式如下



设Ai为N的第i个质因子的倍数的集合,然后套用上面公式即可解决问题了。

关键是将这个公式表达出来,有没有发现一共有2^n项多项式,而且组合数量为奇数时负,组合数量为偶数时符号为正。

代码如下

#include<stdio.h>
#define MAX_N 64
typedef long long LL;
LL par[MAX_N];int u; //a[] 记录N的u个质因子

LL solve(LL A,LL B,LL n){
u=0;
for(int i=2;i*i<=n;i++)
if(n%i==0){
par[u++]=i;
while(n%i==0) n/=i;
}
if(n>1) par[u++]=n;

LL ans=0;

// 2^u种组合  组合数量为奇数时负 为偶数时符号为正
// 用二进制可以方便的表示集合
for(LL i=1;i<(1<<u);i++){
int cnt=0;//组合数量
LL res=1;//组合元素的公倍数
for(int k=0;k<u;k++){
if((i>>k)&1){
res*=par[k];
cnt++;
}
}
if(cnt&1)
ans+=B/res-A/res;
else
ans-=B/res-A/res;
}
return B-A-ans;
}

int main()
{
int T;LL A,B,N;
scanf("%d",&T);
for(int t=1;t<=T;t++){
scanf("%lld%lld%lld",&A,&B,&N);
printf("Case #%d: %lld\n",t,solve(A-1,B,N));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: