您的位置:首页 > 其它

HDU1518 Square (DFS)

2017-02-11 23:03 399 查看


Square

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 14057    Accepted Submission(s): 4439


Problem Description

Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?

 

Input

The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.

 

Output

For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".

 

Sample Input

3
4 1 1 1 1
5 10 20 30 40 50
8 1 7 2 6 4 4 3 5

 

Sample Output

yes
no
yes

 

Source

University of Waterloo Local Contest 2002.09.21

 
思路:一道基础的DFS题目,注意要剪枝,在进行搜索时,如果某一条边还没有搜索完毕,则下次搜索应该从数组a的下一个元素开始,因为在这之前的所有元素都已经搜索过了,再搜索就重复了。

#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;

int a[25],vis[25],flag;

void dfs(int k,int cnt, int cur,int aver, int m){
if(cnt == 3){
flag = 1;
}
if(flag)
return;

for(int i = k; i < m; i ++){
if(!vis[i]){
if(cur + a[i] < aver){
vis[i] = 1;
dfs(i + 1,cnt,cur+a[i],aver,m);
vis[i] = 0;
}
else if(cur + a[i] == aver){
vis[i] = 1;
dfs(0,cnt+1,0,aver,m);
vis[i] = 0;
}
}
}
}

int main(){
int n,m;
scanf("%d",&n);
while(n --){
scanf("%d",&m);
int sum = 0;
for(int i = 0; i < m; i ++){
scanf("%d",&a[i]);
sum += a[i];
}

if(sum % 4){
printf("no\n");
continue;
}
flag = 0;
for(int i = 0; i < m; i ++){
if(a[i] > sum / 4){
flag = 1;
break;
}
}
if(flag){
printf("no\n");
continue;
}
flag = 0;
memset(vis,0,sizeof(vis));
dfs(0,0,0,sum/4,m);
if(flag)
printf("yes\n");
else
printf("no\n");

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: