您的位置:首页 > 其它

Puzzle UVA - 227

2017-02-11 14:42 405 查看

Puzzle UVA - 227

题目描述

A children’s puzzle that was popular 30 years ago consisted of a 5×5 frame which contained 24 small

squares of equal size. A unique letter of the alphabet was printed on each small square. Since there

were only 24 squares within the frame, the frame also contained an empty position which was the same

size as a small square. A square could be moved into that empty position if it were immediately to the

right, to the left, above, or below the empty position. The object of the puzzle was to slide squares

into the empty position so that the frame displayed the letters in alphabetical order.

The illustration below represents a puzzle in its original configuration and in its configuration after

the following sequence of 6 moves:

1) The square above the empty position moves.

2) The square to the right of the empty position moves.

3) The square to the right of the empty position moves.

4) The square below the empty position moves.

5) The square below the empty position moves.

6) The square to the left of the empty position moves.



Input

Input for your program consists of several puzzles. Each is described by its initial configuration and

the sequence of moves on the puzzle. The first 5 lines of each puzzle description are the starting

configuration. Subsequent lines give the sequence of moves.

The first line of the frame display corresponds to the top line of squares in the puzzle. The other

lines follow in order. The empty position in a frame is indicated by a blank. Each display line contains

exactly 5 characters, beginning with the character on the leftmost square (or a blank if the leftmost

square is actually the empty frame position). The display lines will correspond to a legitimate puzzle.

The sequence of moves is represented by a sequence of As, Bs, Rs, and Ls to denote which square

moves into the empty position. A denotes that the square above the empty position moves; B denotes

that the square below the empty position moves; L denotes that the square to the left of the empty

position moves; R denotes that the square to the right of the empty position moves. It is possible that

there is an illegal move, even when it is represented by one of the 4 move characters. If an illegal move

occurs, the puzzle is considered to have no final configuration. This sequence of moves may be spread

over several lines, but it always ends in the digit 0. The end of data is denoted by the character Z.

Output

Output for each puzzle begins with an appropriately labeled number (Puzzle #1, Puzzle #2, etc.). If

the puzzle has no final configuration, then a message to that effect should follow. Otherwise that final

configuration should be displayed.

Format each line for a final configuration so that there is a single blank character between two

adjacent letters. Treat the empty square the same as a letter. For example, if the blank is an interior

position, then it will appear as a sequence of 3 blanks — one to separate it from the square to the left,

one for the empty position itself, and one to separate it from the square to the right.

Separate output from different puzzle records by one blank line.

Note: The first record of the sample input corresponds to the puzzle illustrated above.

Sample Input

TRGSJ

XDOKI

M VLN

WPABE

UQHCF

ARRBBL0

ABCDE

FGHIJ

KLMNO

PQRS

TUVWX

AAA

LLLL0

ABCDE

FGHIJ

KLMNO

PQRS

TUVWX

AAAAABBRRRLL0

Z

Sample Output

Puzzle #1:

T R G S J

X O K L I

M D V B N

W P A E

U Q H C F

Puzzle #2:

A B C D

F G H I E

K L M N J

P Q R S O

T U V W X

Puzzle #3:

This puzzle has no final configuration.

大致题意

给你一个图和一系列的操作,如果能完成的话输出最后的结果,否则输出This puzzle has no final configuration.

思路

简单的模拟

代码如下

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <fstream>
#include <math.h>
#include <algorithm>
#include <climits>
#include <cstring>
#include <string>
#include <set>
#include <queue>
#include <stack>
#include <vector>
#include <list>
#include<sstream>
#include<ctime>
using namespace std;
char map[5][5];
char str[100];
int x,y,l,t,flag;
int main()
{
t=1;
while(1)
{

memset(map,' ',sizeof(map));
memset(str,'\0',sizeof(str));
for(int i=0;i<5;i++)
{
gets(map[i]);
if(map[0][0]=='Z')
return 0;
if(map[i][4]=='\0')
map[i][4]=' ';
}
char c;
l=0;
while((c=getchar())!='0')
{
if(!isspace(c))
str[l++]=c;
}
getchar();

for(int i=0;i<5;i++)
for(int j=0;j<5;j++)
{
if(map[i][j]==' ')
{
x=i;
y=j;
}
}
flag=1;
for(int i=0;i<l;i++)
{
if(str[i]=='A')
{
if(x-1>=0)
{
map[x][y]=map[x-1][y];
map[x-1][y]=' ';
x=x-1;
}
else
{
flag=0;
break;
}
}
else if(str[i]=='B')
{
if(x+1<=4)
{
map[x][y]=map[x+1][y];

d9eb
map[x+1][y]=' ';
x=x+1;
}
else
{
flag=0;
break;
}
}
else if(str[i]=='L')
{
if(y-1>=0)
{
map[x][y]=map[x][y-1];
map[x][y-1]=' ';
y=y-1;
}
else
{
flag=0;
break;
}
}
else if(str[i]=='R')
{
if(y+1<=4)
{
map[x][y]=map[x][y+1];
map[x][y+1]=' ';
y=y+1;
}
else
{
flag=0;
break;
}
}
}
if(t!=1)
printf("\n");
printf("Puzzle #%d:\n",t);
if(flag==1)
{
for(int i=0;i<5;i++)
{
printf("%c",map[i][0]);
for(int j=1;j<5;j++)
printf(" %c",map[i][j]);
printf("\n");
}
}
else
printf("This puzzle has no final configuration.\n");
t++;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: