您的位置:首页 > 其它

PAT B1038. 统计同成绩学生(20)

2017-02-10 21:51 260 查看
本题要求读入N名学生的成绩,将获得某一给定分数的学生人数输出。

输入格式:

输入在第1行给出不超过105的正整数N,即学生总人数。随后1行给出N名学生的百分制整数成绩,中间以空格分隔。最后1行给出要查询的分数个数K(不超过N的正整数),随后是K个分数,中间以空格分隔。

输出格式:

在一行中按查询顺序给出得分等于指定分数的学生人数,中间以空格分隔,但行末不得有多余空格。
输入样例:
10
60 75 90 55 75 99 82 90 75 50
3 75 90 88

输出样例:
3 2 0

#include <cstdio>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <map>
#include <string>
#define Max 20000
using namespace std;

int main()
{
int S[101]={0};
int n,m,k;
scanf("%d",&n);
for(int i=0;i<n;i++)
{
scanf("%d",&k);
S[k]++;
}
scanf("%d",&m);
for(int i=0;i<m;i++)
{
scanf("%d",&k);
printf("%d",S[k]);
if(i==m-
4000
1)  printf("\n");
else printf(" ");
}
system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: