您的位置:首页 > 其它

PAT 1094 The Largest Generation

2017-02-10 19:43 453 查看


1094. The Largest Generation (25)

时间限制

200 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01
4000
to N), and M (<N) which is the number of family
members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID's of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated
by a space.

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.
Sample Input:
23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18

Sample Output:
9 4

题目:

找出一棵树中元素最多的一层,输出这层有几个元素和这是第几层

CalLevelChildren函数用的递归,比较有用的工具!

Code:

// start at 16:37
#include <iostream>
#include <string>
#include <vector>
#include <queue>
#include <stdio.h>
#include <algorithm>
#define MAXN 101

struct TreeNode {
int vaule;
TreeNode* first_child;
TreeNode* next_sibling;
};

int CalLevelChildren(TreeNode* node, int level, int count) {
if (level == 1) {
return 1;
}
TreeNode* temp = node->first_child;
while (temp) {
count += CalLevelChildren(temp, level-1, 0);
temp = temp->next_sibling;
}
return count;
}
int main() {
int m, n;
std::cin >> m;
std::cin >> n;
if (m == 1) {
printf("1 1");
return 0;
}
TreeNode* nodes[MAXN];
for (int i = 1; i < m+1; i++) {
nodes[i] = (TreeNode*)malloc(sizeof(TreeNode));
nodes[i]->first_child = NULL;
nodes[i]->next_sibling = NULL;
nodes[i]->vaule = i;
}
while (n--) {
int parent;
int children_num;
int first;
std::cin >> parent;
std::cin >> children_num;
std::cin >> first;
nodes[parent]->first_child = nodes[first];
children_num--;
int this_input;
int prior = first;
while (children_num--) {
std::cin >> this_input;
nodes[prior]->next_sibling = nodes[this_input];
prior = this_input;
}
}
std::queue<TreeNode*> q;
q.push(nodes[1]);
while (!q.empty()) {
TreeNode* t = q.front();
q.pop();
TreeNode* children = t->first_child;
while (children) {
q.push(children);
children = children->next_sibling;
}
}
std::vector<int> levelnodes;
for (int i = 1; i < m;i++) {
int count = 0;
if (CalLevelChildren(nodes[1], i, count)) {
levelnodes.push_back(CalLevelChildren(nodes[1], i, count));
} 
}
std::vector<int> l = levelnodes;
sort(levelnodes.begin(), levelnodes.end());
for (int i = 0; i < l.size(); i++) {
if (levelnodes.back() == l[i]) {
printf("%d %d", levelnodes.back(), i+1);
}
}
system("pause");
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: