您的位置:首页 > 其它

POJ 1905-Expanding Rods(二分法-中心移动距离)

2017-02-09 13:00 393 查看
Expanding Rods

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 15779 Accepted: 4196
Description


When a thin rod of length L is heated n degrees, it expands to a new length L'=(1+n*C)*L, where C is the coefficient of heat expansion. 

When a thin rod is mounted on two solid walls and then heated, it expands and takes the shape of a circular segment, the original rod being the chord of the segment. 

Your task is to compute the distance by which the center of the rod is displaced. 

Input

The input contains multiple lines. Each line of input contains three non-negative numbers: the initial lenth of the rod in millimeters, the temperature change in degrees and the coefficient of heat expansion of the material. Input data guarantee that no rod
expands by more than one half of its original length. The last line of input contains three negative numbers and it should not be processed.
Output

For each line of input, output one line with the displacement of the center of the rod in millimeters with 3 digits of precision. 

Sample Input
1000 100 0.0001
15000 10 0.00006
10 0 0.001
-1 -1 -1

Sample Output
61.329
225.020
0.000

Source

Waterloo local 2004.06.12



题目意思:

有一根棍子受热会弯曲成一段圆弧,求受热前后中心的移动距离,也就是图中的ans。

解题思路:

l是原长,ll是受热弯曲后的长度,补全圆弧所在扇形,半径为R,根据几何数学计算公式推导出图中最下面两个式子。

对ans在[0,0.5*l]的范围内二分枚举计算出对应的R值,代入后计算出的值与ll比较:如果大于ll,说明ans大了,改变范围取前二分之一;反正,说明ans取小了,改变范围取后二分之一。

此外,由于全部是double型,所以要注意比较时的精度。

#include<iostream>
#include<cstdio>
#include<iomanip>
#include<cmath>
#include<cstdlib>
#include<cstring>
#include<map>
#include<algorithm>
using namespace std;
#define INF 0xfffffff
const double eps = 1e-8;
#define MAXN 50050
const double PI = acos(-1.0);
int a[MAXN];
double l,ll,n,c,r,high,low,mid;

int main()
{
#ifdef ONLINE_JUDGE
#else
freopen("F:/cb/read.txt","r",stdin);
//freopen("F:/cb/out.txt","w",stdout);
#endif
ios::sync_with_stdio(false);
cin.tie(0);
while(cin>>l>>n>>c)
{
if(l<0&&n<0&&c<0)break;
high=l/2,low=0;
ll=(1+n*c)*l;
while(high-low>eps)
{
mid=(low+high)/2;
r=(4*mid*mid+l*l)/(8*mid);
if(2*r*asin(l/(2*r))<ll)
low=mid;
else
high=mid;
}
cout<<fixed<<setprecision(3)<<mid<<endl;
}
return 0;
}
/*
1000 100 0.0001 15000 10 0.00006 10 0 0.001 -1 -1 -1*/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息