您的位置:首页 > 其它

HDU-1969 PIE 二分法

2017-02-08 22:45 295 查看

Pie

My birthday is coming up and traditionally I’m serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. **This should be one piece of one pie, not several small pieces since that looks messy. **This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

Input

One line with a positive integer: the number of test cases. Then for each test case:

—One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.

—One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.

Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).

Sample Input

3

3 3

4 3 3

1 24

5

10 5

1 4 2 3 4 5 6 5 4 2

Sample Output

25.1327

3.1416

50.2655

这个题目的题意就是找出一个最大的实数V满足:能从有的派中取出至少N+1个V,注意是取出而不能凑出

如果考虑直接求解无疑是很麻烦的事,至少笔者自己想不出可以直接算出这个最大实数的方法,但是如果有一个数后确定这个数是不是满足条件的就容易多了,只需要用V一一去除各蛋糕对应的体积,把所得结果取整相加与N+1比较即可。

这个思路感觉没什么好说的就直接上代码把

代码

#include <iostream>
#include <vector>
#include <cmath>
const double pi =acos(-1.0);
using namespace std;
vector<double> pie;
int cnt(double x);
int main()
{
int  N,n1,n2,i;
double s,temp,max,min,mid;
cin>>N;
while(N--){
max=0;
cin>>n1>>n2;
s=0;
while(n1--){
cin>>temp;
if(max<temp){
max=temp;
}
pie.push_back(temp*temp*pi);
}

4000
max*=max*pi,min=0;
mid=(max+min)/2;
while((max-min)>1e-6){
if(cnt(mid)<n2+1){
max=mid;
}else{
min=mid;
}
mid=(max+min)/2;
}
printf("%.4f\n",mid);
pie.clear();
}
}
int cnt(double x)
{
int i=0;
for(auto y:pie){
i+=(int)(y/x);/*注意此处的(int),如果没有在vjudge上会WA,笔者不知道是不是
因为有的情况下会进行四舍五入导致计数出错,希望有大牛能指点一下*/
}
return i;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: