您的位置:首页 > 编程语言 > C语言/C++

简单编码 (sdut oj)

2017-02-08 22:30 176 查看




简单编码

Time Limit: 1000MS Memory Limit: 65536KB


Problem Description

将一串文本译成密码,密码的规律是:

将原来的小写字母全部翻译成大写字母,大写字母全部翻译成小写字母,数字的翻译规律如下:

0——>9 

1——>8 

2——>7 

3——>6 

4——>5 

5——>4 

6——>3 

7——>2

8——>1 

9——>0 

然后将所有字符的顺序颠倒。




Input

输入一串文本,最大字符个数不超过100。




Output

输出编码后的结果。




Example Input

china





Example Output

ANIHC



Hint


Author

参考代码

#include<stdio.h>
#include<string.h>
int main()
{
char a[101];
char b[101];
gets(a);
int n = strlen(a);
int i;
for(i = 0; i < n; i++)
{
if(a[i] >= 'a' && a[i] <= 'z')
{
b[i] = a[i] - 32;
}
else if(a[i] >= 'A' && a[i] <= 'Z')
{
b[i] = a[i] + 32;
}
else if(a[i] >= 48 && a[i] <= 57)
{
b[i] = 105 - a[i];
}
}
for(i = n - 1; i >= 0; i--)
{
printf("%c",b[i]);
}
printf("\n");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  OJ SDUT c语言 字符串