您的位置:首页 > 其它

ZOJ 3609 Modular Inverse【exgcd】

2017-02-08 18:53 337 查看
Modular Inverse
Time Limit: 2 Seconds      Memory Limit: 65536 KB

The modular modular multiplicative inverse of an integer a modulo m is an integer x such that 
a-1≡x (mod m)
.
This is equivalent to 
ax≡1 (mod m)
.

Input

There are multiple test cases. The first line of input is an integer T ≈ 2000 indicating the number of test cases.
Each test case contains two integers 0 < a ≤ 1000 and 0 < m ≤ 1000.

Output

For each test case, output the smallest positive x. If such x doesn't exist, output "Not Exist".

Sample Input

3
3 11
4 12
5 13

Sample Output

4
Not Exist
8


思路:扩展欧几里德(推导过程:ax=1(mod m)→ (ax-1)%m==0→ax+my=1)

#include<cstdio>
#include<math.h>
#include<cstring>
#include<climits>
#include<string>
#include<queue>
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<climits>
#include<string>
#include<queue>
#include<stack>
#include<set>
#include<map>
#include<algorithm>
using namespace std;
#define rep(i,j,k)for(i=j;i<k;i++)
#define per(i,j,k)for(i=j;i>k;i--)
#define MS(x,y)memset(x,y,sizeof(x))
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define ll long long
#define abs(x) (x>0?x:-x)
const int INF=0x7ffffff;
const ll MAX=1e18;

const int M=1e3+10;
int i,j,k,n,m;
int a,d,x,y;

int exgcd(int a,int b,int &x,int &y)
{
if(!b){
x=1;y=0;return a;
}
int t,d;
d=exgcd(b,a%b,x,y);
t=x;x=y;y=t-a/b*y;
return d;
}

int main()
{
int T;
scanf("%d",&T);
while(T--){
scanf("%d%d",&a,&m);
d=exgcd(a,m,x,y);
if(d==1){
while(x<=0)
x+=m;
printf("%d\n",x);
}
else printf("Not Exist\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: