您的位置:首页 > 其它

ZOJ 3607 Lazier Salesgirl【贪心】

2017-02-08 18:37 489 查看
Lazier Salesgirl
Time Limit: 2 Seconds      Memory Limit: 65536 KB

Kochiya Sanae is a lazy girl who makes and sells bread. She is an expert at bread making and selling. She can sell the i-th customer a piece of bread for price pi.
But she is so lazy that she will fall asleep if no customer comes to buy bread for more than w minutes. When she is sleeping, the customer coming to buy bread will leave immediately. It's known that she starts to sell bread now and the i-th
customer come after ti minutes. What is the minimum possible value of w that maximizes the average value of the bread sold?

Input

There are multiple test cases. The first line of input is an integer T ≈ 200 indicating the number of test cases.
The first line of each test case contains an integer 1 ≤ n ≤ 1000 indicating the number of customers. The second line contains n integers 1 ≤ pi ≤
10000. The third line contains n integers 1 ≤ ti ≤ 100000. The customers are given in the non-decreasing order of ti.

Output

For each test cases, output w and the corresponding average value of sold bread, with six decimal digits.

Sample Input

2
4
1 2 3 4
1 3 6 10
4
4 3 2 1
1 3 6 10

Sample Output

4.000000 2.500000
1.000000 4.000000

思路:找出每个数的w,再枚举

#include<cstdio>
#include<math.h>
#include<cstring>
#include<climits>
#include<string>
#include<queue>
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<climits>
#include<string>
#include<queue>
#include<stack>
#include<set>
#include<map>
#include<algorithm>
using namespace std;
#define rep(i,j,k)for(i=j;i<k;i++)
#define per(i,j,k)for(i=j;i>k;i--)
#define MS(x,y)memset(x,y,sizeof(x))
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define ll long long
#define abs(x) (x>0?x:-x)
const int INF=0x7ffffff;
const ll MAX=1e18;

const int M=1e3+10;
double p[M];
int t[M],w[M];
int i,j,k,n,m;
double ans1,ans2,sum;

void work()
{
ans1=0;
w[1]=t[1];
for(int i=2;i<=n;i++)
w[i]=max(w[i-1],t[i]-t[i-1]);
for(int i=1;i<=n;i++){
int cur=w[i];
sum=0;
for(j=1;j<=n;j++){
if(w[j]<=cur)
sum+=p[j];
else break;
}
j--;
if(sum/j>ans1)
ans1=sum/j,ans2=cur;
}
}

int main()
{
int T;
scanf("%d",&T);
while(T--){
scanf("%d",&n);
for(i=1;i<=n;i++)scanf("%lf",&p[i]);
for(i=1;i<=n;i++)scanf("%d",&t[i]);
work();
printf("%.6lf %.6lf\n",ans2,ans1);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: