您的位置:首页 > Web前端

poj2492 A Bug's Life

2017-02-08 17:02 351 查看
A Bug's Life

Time Limit: 10000MS Memory Limit: 65536K
Total Submissions: 35520 Accepted: 11650
Description

Background 

Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy
to identify, because numbers were printed on their backs. 
Problem 

Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each
interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual
behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.
Sample Input
2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output
Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

Hint

Huge input,scanf is recommended.

趁热打铁,马上找了带权并查集的题来做一做。

这个题就是告诉你两个虫子的性别不一样,然后问你存不存在关系产生矛盾的虫子。像第一组示例,1、2不同,2、3不同,那么1 3 应该是同性,结果又出来个1 3.所以产生了矛盾。

比较基础的带权并查集,也是两个状态。

没学过带权并查集的可以先看下这里:点击打开链接

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int MAXN=2010;
int n,m;
int pre[MAXN],relation[MAXN];

int findx(int x)
{
if(pre[x]==x)return x;
int order=pre[x];
pre[x]=findx(pre[x]);
relation[x]=(relation[x]+relation[order])%2;
return pre[x];
}

int main()
{
int i;
int t;
scanf("%d",&t);
for(int tt=1; tt<=t; ++tt)
{
scanf("%d%d",&n,&m);
int x,y;
int flag=0;
for(i=1;i<=n;++i)
{
pre[i]=i;
relation[i]=0;
}
for(i=1; i<=m; ++i)
{
scanf("%d %d",&x,&y);
if(flag)continue;
int a=findx(x),b=findx(y);
if(a!=b)
{
pre[b]=a;
relation[b]=(relation[x]-relation[y]+1)%2;
}
else
{
int p=(relation[x]-relation[y]+2)%2;
if(!p)
{
flag=1;
}
}
}
printf("Scenario #%d:\n",tt);
if(flag)puts("Suspicious bugs found!\n");
else puts("No suspicious bugs found!\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj 带权并查集