您的位置:首页 > 其它

LA 3644 X-Plosives

2017-02-07 11:11 274 查看
原题:

A secret service developed a new kind of explosive that attain its volatile property only when a specific association of products occurs. Each product is a mix of two different simple compounds, to which we call a binding pair. If N > 2, then mixing N different binding pairs containing N simple compounds creates a powerful explosive. For example, the binding pairs A+B, B+C, A+C (three pairs, three compounds) result in an explosive, while A+B, B+C, A+D (three pairs, four compounds) does not. You are not a secret agent but only a guy in a delivery agency with one dangerous problem: receive binding pairs in sequential order and place them in a cargo ship. However, you must avoid placing in

the same room an explosive association. So, after placing a set of pairs, if you receive one pair that might produce an explosion with some of the pairs already in stock, you must refuse it, otherwise, you must accept it. An example. Lets assume you receive the following sequence: A+B, G+B, D+F, A+E, E+G, F+H. You would accept the first four pairs but then refuse E+G since it would be possible to make the following explosive with the previous pairs: A+B, G+B, A+E, E+G (4 pairs with 4 simple compounds). Finally, you would accept the last pair, F+H. Compute the number of refusals given a sequence of binding pairs.

Input

The input will contain several test cases, each of them as described below. Consecutive

test cases are separated by a single blank line. Instead of letters we will use integers to represent compounds. The input contains several lines. Each line (except the last) consists of two integers (each integer lies between 0 and 10 5 ) separated by a single space, representing a binding pair. Each test case ends in a line with the number ‘-1’. You may assume that no repeated binding pairs appears in the input.

Output

For each test case, the output must follow the description below. A single line with the number of refusals.

Sample Input

1 2

3 4

3 5

3 1

2 3

4 1

2 6

6 5

-1

Sample Output

3

中文:

给你几组数a和b,表示a和b会形成化合物,如果有有超过3个物品互相形成化合物就会爆炸。这样的物品不能装上车,如果让你按照给出的顺序把这些物品装上车,有多少组不能够装上车?

#include <bits/stdc++.h>
using namespace std;
int father[100001];

int Find(int x)
{
if(father[x]==x)
return x;
return father[x]=Find(father[x]);
}
int main()
{
ios::sync_with_stdio(false);
int a,b,ans=0;
for(int i=1;i<=100000;i++)
father[i]=i;
while(cin>>a)
{
if(a!=-1)
{
cin>>b;
int x=Find(a);
int y=Find(b);
if(x==y)
ans++;
else
father[x]=y;
}
else
{
cout<<ans<<endl;
ans=0;
for(int i=1;i<=100000;i++)
father[i]=i;
}
}
return 0;
}


解:

裸的并查集判断环即可。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: