您的位置:首页 > 其它

poj 2352 Stars(线段树 )

2017-02-07 11:01 567 查看
Stars

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 45051 Accepted: 19558
Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know
the distribution of the levels of the stars. 



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level
0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.
Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars
are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
Sample Input
5
1 1
5 1
7 1
3 3
5 5

Sample Output
1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

题目大意:

给你n个点代表n个星星,以该点为起点向x,y轴作垂线,会得到一个矩形,这个矩形里面所包含的星星数(不包括它本身)称为该星星的等级

,要求输出在0-n-1等级各有多少个星星。注意给出的点的顺序很有讲究,是按照y坐标升序给出,如果y坐标相同,则按照x坐标升序给出,题目

这样说就相当于减少了这个题目的难度,如果题目没有给出这样的提示,我们也需要这样进行处理。

#include <stdio.h>
#include <string.h>
#define size 33000
#define lson l, m, rt<<1
#define rson m+1, r, rt<<1|1
int sum[size << 2],level[size], x[size];
void pushup( int rt)
{
sum[rt] = sum[rt << 1] + sum[rt << 1 | 1];
}
void build( int p, int l, int r, int rt)
{
if( l == r)
{
sum[rt]++;return;
}
int m = ( l + r) >> 1;
if( p <= m ) build(p, lson);
else build(p, rson);
pushup(rt);
}
int qurey( int L, int R, int l, int r, int rt )
{
if( L <= l && r <= R) return sum[rt];
int m = (l + r) >> 1;
int ans = 0;
if( L <= m) ans+=qurey(L, R, lson);
if( R > m)  ans+=qurey(L, R, rson);
pushup(rt);
return ans;
}
int main()
{
int n;
while(~scanf("%d", &n))
{
memset(sum, 0, sizeof(sum));
memset(level,0,sizeof(level));
int y, maxn = -1;
for( int i = 0; i < n; i++)
{
scanf("%d%d",&x[i],&y);
if(maxn < x[i]) maxn = x[i];
}

for( int i = 0; i < n; i++)
{
level[qurey(0, x[i], 0, maxn, 1)]++;
build(x[i],0,maxn,1);

}
for( int i = 0; i < n; i++)
printf("%d\n",level[i]);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: