您的位置:首页 > 其它

HPUOJ--2017寒假作业-专题0/P-贪心

2017-02-06 19:35 411 查看


P - TIANKENG’s restaurant

 

TIANKENG manages a restaurant after graduating from ZCMU, and tens of thousands of customers come to have meal because of its delicious dishes. Today n groups of customers come to enjoy their meal, and there are Xi persons in the
ith group in sum. Assuming that each customer can own only one chair. Now we know the arriving time STi and departure time EDi of each group. Could you help TIANKENG calculate the minimum chairs he needs to prepare so that every customer can take a seat when
arriving the restaurant?

InputThe first line contains a positive integer T(T<=100), standing for T test cases in all. 

Each cases has a positive integer n(1<=n<=10000), which means n groups of customer. Then following n lines, each line there is a positive integer Xi(1<=Xi<=100), referring to the sum of the number of the ith group people, and the arriving time STi and departure
time Edi(the time format is hh:mm, 0<=hh<24, 0<=mm<60), Given that the arriving time must be earlier than the departure time. 

Pay attention that when a group of people arrive at the restaurant as soon as a group of people leaves from the restaurant, then the arriving group can be arranged to take their seats if the seats are enough. 

OutputFor each test case, output the minimum number of chair that TIANKENG needs to prepare.
Sample Input
2
2
6 08:00 09:00
5 08:59 09:59
2
6 08:00 09:00
5 09:00 10:00


Sample Output
11
6

#include<cstdio>
#include<cstring> 
int main()//因为这道题最小时间单位是分钟,所以可以把时间由几时几分化为分钟。 
{//所以就可以找出哪一个时间点,即哪一个分钟内的人最多。 
  int T,n,i,sh,sm,eh,em,time[1440+11],x,st,ed,j,max;
  scanf("%d",&T);
  while(T--)
  {
  memset(time,0,sizeof(time));//6
  scanf("%d",&n);
  for(i=0;i<n;i++)
  {
  scanf("%d %d:%d %d:%d",&x,&sh,&sm,&eh,&em);
  st=sh*60+sm;
  ed=eh*60+em;//时间形式的转换 
  for(j=st;j<ed;j++)
  {
  time[j]+=x;//把一个时间段转化为一个区间,用数组来表示,数组的下标即为时刻,时间段上下限之内的下标依次加1. 
}//同一时间段内,即区间内,每一个量都是对应的人数。 
}//通过叠加,哪个时刻人最多,就很容易了。 
max=time[0];
for(j=1;j<1440+11;j++)
{
if(time[j]>max)
max=time[j];
}//最后一步就是找出最大值了。嘿嘿。 
printf("%d\n",max);
 } 
 return 0;
}
 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: