您的位置:首页 > 其它

POJ 2456 Aggressive cows(二分+贪心 计算个数)

2017-02-05 16:40 148 查看
Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them
is as large as possible. What is the largest minimum distance?

Input
* Line 1: Two space-separated integers: N and C

* Lines 2..N+1: Line i+1 contains an integer stall location, xi
Output
* Line 1: One integer: the largest minimum distance
Sample Input
5 3
1
2
8
4
9

Sample Output
3

Hint
OUTPUT DETAILS:

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.

Huge input data,scanf is recommended

思路:二分法+贪心

如果不适用贪心,很容易时间超限。

贪心思路:最小间隔0与最大间隔(str
-str[0])/(C-1),距离不断缩小,直到区间为0。
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <set>
#include <string>
#include <cstring>
#include <cmath>
using namespace std;
typedef long long ll;
int n,c;
int a[1000005];
int cal(int k) //计算符号条件的
{
int imax=a[1],sum=0;
for(int i=1;i<=n;i++)
{
if(a[i]-imax>=k)
{
sum++;
imax=a[i];
}
}
return sum>=c-1? 1:0;
}
int main()
{
while(scanf("%d%d",&n,&c)==2)
{
for(int i=1;i<=n;i++)
scanf("%d",&a[i]);
sort(a+1,a+n+1);
int l=0,r=(a
-a[1])/(c-1),mid,res; //二分距离
while(l<=r)
{
mid=(l+r)/2;
if(cal(mid))
{
res=mid;
l=mid+1;
}

else
r=mid-1;
}
printf("%d\n",res);//这一点我开始错误,误以为是mid ,
//最后一次循环肯定是left==right==mid, 但是mid 有可能不能放下c 只羊,
//我们能够确定left 左边的能够放下c 只羊,right 右边的不能放下c 只羊,
//可是mid 不能确定;如果mid 能够放下,则left 右移,left=right+1 ,显然不能放下
//,则left-1 是最大值;如果mid 不能放下,则left 不变,left 依然不能不能放下,left-1 是最大值。
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  贪心 二分法 poj