您的位置:首页 > 其它

POJ 1789 Truck History

2017-02-05 12:34 387 查看
Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company’s history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on.

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan – i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as

1/Σ(to,td)d(to,td)

where the sum goes over all pairs of types in the derivation plan such that t o is the original type and t d the type derived from it and d(t o,t d) is the distance of the types.

Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan.

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

Output

For each test case, your program should output the text “The highest possible quality is 1/Q.”, where 1/Q is the quality of the best derivation plan.

Sample Input

4

aaaaaaa

baaaaaa

abaaaaa

aabaaaa

0

Sample Output

The highest possible quality is 1/3.

题意:aaaaaaa是初始字符串。给一个数N,输入N行字符串,两行字符串相同位置的字符相异的数量为两个字符串的距离。使用到所有的字符串,求距离之和的最小值。

一个字符串可以看成一个节点,两个节点的边就是字符串距离,求这个图的最小生成树的边的和。

Kruskal求解

#include<iostream>
#include<vector>
#include<algorithm>
#include<cstdlib>
#include<cmath>
#include<stack>
#include<queue>
#include<cstdio>
#include<string>
#include<cstring>
#include<string.h>
#include<map>
#include<set>
using namespace std;
#define N 2000+5
#define NN 10000
#define INF 0x3f3f3f3f
/*****************************************************/
char str
[10];
int par
;
int ranks
;
struct node{
int u, v, w;
};

node s[4000000];
bool cmp(node a, node b){
return a.w < b.w;
}
bool same(int a, int b);
int find(int x);
void unite(int a, int b);
int main()
{
int n;
while (cin >> n){
if (n == 0)break;
for (int i = 0; i < n; i++){
scanf("%s", str[i]);
}
int E = 0;
int res = 0;
for (int i = 0; i < n; i++){
for (int j = 1 + i; j < n; j++){
int cnt = 0;
for (int k = 0; k < 7; k++){
if (str[i][k] != str[j][k]){
cnt++;
}
}
s[E].u = i, s[E].v = j, s[E].w = cnt;
E++;                   //边的数量
}
}
sort(s, s + E, cmp);
for (int i = 0; i < n; i++){
par[i] = i;
ranks[i] = 1;
}

for (int i = 0; i < E; i++){
if (!same(s[i].u, s[i].v)){
unite(s[i].u, s[i].v);
res += s[i].w;
}
}
printf("The highest possible quality is 1/%d.\n", res);

}
}
int find(int x){
if (x == par[x])return x;
return par[x] = find(par[x]);
}
bool same(int a, int b){
a = find(a);
b = find(b);
if (a == b)return true;
return false;
}
void unite(int a, int b){
a = find(a);
b = find(b);
if (a == b)return;
if (ranks[a] < ranks[b]){
par[a] = b;
}
else{
if (ranks[a] == ranks[b])
ranks[a]++;
par[b] = a;
}
}


Prim求解

#include<iostream>
#include<vector>
#include<algorithm>
#include<cstdlib>
#include<cmath>
#include<stack>
#include<queue>
#include<cstdio>
#include<string>
#include<cstring>
#include<string.h>
#include<map>
#include<set>
using namespace std;
#define N 2000+5
#define NN 10000
#define INF 0x3f3f3f3f
/*****************************************************/
char str
[10];
int cost

;
int d
;
bool used
;

int main()
{
int n;
while (cin >> n){
if (n == 0)break;
for (int i = 0; i < n; i++){
scanf("%s", str[i]);
}
memset(d, 0x3f, sizeof(d));
memset(used, 0, sizeof(used));
for (int i = 0; i < n; i+
bda1
+){
for (int j = 0; j < n; j++){
int cnt = 0;
for (int k = 0; k < 7; k++){
if (str[i][k] != str[j][k]){
cnt++;
}
}
cost[i][j] = cost[j][i] = cnt;
}
}
d[0] = 0;
int res = 0;
while (1){
int v = -1;
for (int i = 0; i < n; i++){
if (!used[i] && (v == -1 || d[i] < d[v]))
v = i;
}
if (v == -1)break;
used[v] = true;
res += d[v];
for (int i = 0; i < n; i++){
d[i] = min(d[i], cost[v][i]);
}
}

printf("The highest possible quality is 1/%d.\n", res);

}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  kruskal-水