您的位置:首页 > 大数据 > 人工智能

Repair the wall

2017-02-04 23:19 369 查看
Long time ago , Kitty lived in a small village. The air was fresh and the scenery was very beautiful. The only thing that troubled her is the typhoon. When the typhoon came, everything is terrible. It kept blowing and raining for a long time. And what made the situation worse was that all of Kitty's walls were made of wood. One day, Kitty found that there was a crack in the wall. The shape of the crack is a rectangle with the size of 1×L (in inch). Luckly Kitty got N blocks and a saw(锯子) from her neighbors. The shape of the blocks were rectangle too, and the width of all blocks were 1 inch. So, with the help of saw, Kitty could cut down some of the blocks(of course she could use it directly without cutting) and put them in the crack, and the wall may be repairedperfectly, without any gap. Now, Kitty knew the size of each blocks, and wanted to use as fewer as possible4000of the blocks to repair the wall, could you help her ? InputThe problem contains many test cases, please process to the end of file( EOF ). Each test case contains two lines. In the first line, there are two integers L(0<L<1000000000) and N(0<=N<600) whichmentioned above. In the second line, there are N positive integers. The i th integer Ai(0<Ai<1000000000 ) means that the i th block has the size of 1×Ai (in inch). OutputFor each test case , print an integer which represents the minimal number of blocks are needed. If Kitty could not repair the wall, just print "impossible" instead. Sample Input
5 3
3 2 1
5 2
2 1
Sample Output
2
impossible
#include<cstdio>
#include<algorithm>
using namespace std;
int a[600];
bool cmp(int a,int b){
return a > b;
}
int main(){
int  l,n;
while (~scanf("%d%d",&l,&n)){
long long sum = 0;
for (int i = 0; i < n; ++i){
scanf("%d",&a[i]);
}
sort(a,a+n,cmp);
int count = 0;
for (int i = 0; i < n; ++i){
sum += a[i];
count++;
if (sum >= l)
break;
}
if (sum < l)
printf("impossible\n");
else
printf("%d\n",count);
}
return 0;
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: