您的位置:首页 > 其它

HDU-1443 Joseph

2017-02-03 22:23 351 查看


Joseph

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 2589    Accepted Submission(s): 1540


Problem Description

The Joseph's problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, . . ., n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved.
Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved.

Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy. 

 

Input

The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14. 

 

Output

The output file will consist of separate lines containing m corresponding to k in the input file. 

 

Sample Input

3
4
0

 

Sample Output

5
30

 

Source

ACM暑期集训队练习赛(5)

 

Recommend

lcy

约瑟夫环问题

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

int mark[15];// ,2,7,5,30,169,441,1872,7632,1740,93313,459901,1358657,2504881
int work(int a,int b)
{
int cnt=0;
int sum=2*a;
int mod=b%(2*a);
if(!mod) mod=sum;

while(mod>a)
{
sum--;
mod=(mod+b-1)%sum;//求余数去除前后,位置等效于前一个
if(!mod) mod=sum;
cnt++;
}
return cnt;
}

int solve(int a)
{
for(int i=a+1;;i++)//缩短循环次数,注意下for循环的内部
{
if(work(a,i)==a)//当为a的次数的时候就找到
return i;
}
}

void init()
{
for(int i=1;i<15;i++)
{
mark[i]=solve(i);
}
}

int main()
{
int k;
init();
while(~scanf("%d",&k)&&k)
{
cout<<mark[k]<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: