您的位置:首页 > 其它

PAT A1046. Shortest Distance (20)

2017-02-03 11:33 369 查看
The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 ... DN,
where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive
integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.
Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:
3
10
7

#include <cstdio>
#include <algorithm>
#define Max 100010
using namespace std;

int main()
4000

{
int n,v[Max]={0},sum[Max]={0};
scanf("%d",&n);
for(int i=1;i<=n;i++)
{
scanf("%d",&v[i]);
sum[i+1]=sum[i]+v[i];
}
int m;
scanf("%d",&m);
for(int j=0;j<m;j++)
{
int a,b,l1=0,l2=0;
scanf("%d%d",&a,&b);
int flag;
if(a>b)
{
flag =a ;
a=b;
b=flag;
}
l1=sum[b]-sum[a];
l2=sum[n+1]-l1;
if(l1>l2)
{
flag =l1 ;
l1=l2;
b=flag;
}
printf("%d\n",l1);
}
system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: