您的位置:首页 > 其它

HDU1020

2017-02-03 00:40 204 查看
杭电1020题

Problem Description

Given a string containing only ‘A’ - ‘Z’, we could encode it using the following method:

Each sub-string containing k same characters should be encoded to “kX” where “X” is the only character in this sub-string.

If the length of the sub-string is 1, ‘1’ should be ignored.

Input

The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only ‘A’ - ‘Z’ and the length is less than 10000.

Output

For each test case, output the encoded string in a line.

Sample Input

2

ABC

ABBCCC

Sample Output

ABC

A2B3C

代码:

#include <iostream>
#include <cstdio>
#include <string.h>
using namespace std;

int main()
{
int n=0;
//数组开大点,,,第一次提交的时候因为数组开的太小了,导致了RunTime Error
char str[100001];
cin>>n;
while(n--)
{
scanf("%s",str);
int num=1, i;
for(i=0;i<strlen(str);i++)
{
while(str[i]==str[i+1])
num++,i++;
if(num!=1)
printf("%d%c",num,str[i]);
else
printf("%c",str[i]);
num=1;
}
i--;
cout<<endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: