您的位置:首页 > 其它

HDU2141:Can you find it?(二分 + 优化)

2017-02-02 19:46 295 查看


Can you find it?

Time Limit: 10000/3000 MS (Java/Others)    Memory Limit: 32768/10000 K (Java/Others)

Total Submission(s): 27166    Accepted Submission(s): 6840


Problem Description

Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.

 

Input

There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth
line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.

 

Output

For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".

 

Sample Input

3 3 3
1 2 3
1 2 3
1 2 3
3
1
4
10

 

Sample Output

Case 1:
NO
YES
NO

 

Author

wangye

 

Source

HDU 2007-11 Programming Contest
题意:判断能否从三组数据各选一个和为Si。

思路:将前两组的和的情况列举出来,排序后二分第三组即可。

# include <stdio.h>
# include <algorithm>
using namespace std;
int main()
{
int cas=1, tmp, s, a[3][501];
long long b[250001];
while(~scanf("%d%d%d",&a[0][0],&a[1][0],&a[2][0]))
{
for(int i=0; i<3; ++i)
for(int j=1; j<=a[i][0]; ++j)
scanf("%d",&a[i][j]);
int l, r, mid, cnt = 0;
scanf("%d",&s);
printf("Case %d:\n",cas++);
for(int i=1; i<=a[0][0]; ++i)
for(int j=1; j<=a[1][0]; ++j)
b[cnt++] = a[0][i] + a[1][j];
sort(a[2]+1, a[2]+a[2][0]+1);
sort(b, b+cnt);
cnt = unique(b, b+cnt)-b;//去重优化
while(s--)
{
bool flag = false;
scanf("%d",&tmp);
if(tmp>a[2][a[2][0]]+b[cnt-1] || tmp<a[2][1]+b[0])//优化
{
puts("NO");
continue;
}
for(int i=1; i<=a[2][0]; ++i)
{
l = 0;
r = cnt-1;
mid = (l+r)>>1;
while(l<r)
{
if(b[mid]+a[2][i]<tmp)
l = mid+1;
else
r = mid;
mid = (l+r)>>1;
}
if(b[r]+a[2][i]==tmp)
{
flag = true;
break;
}
}
if(flag)
puts("YES");
else
puts("NO");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: