您的位置:首页 > 其它

HDU2199:Can you solve this equation?(数学 + 二分)

2017-02-02 14:19 543 查看


Can you solve this equation?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 19065    Accepted Submission(s): 8406


Problem Description

Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;

Now please try your lucky.

 

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);

 

Output

For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.

 

Sample Input

2
100
-4

 

Sample Output

1.6152
No solution!

 

Author

Redow
思路:二分解方程。
# include <stdio.h>
# include <math.h>
double fun(double x)
{
return 8*x*x*x*x + 7*x*x*x + 2*x*x + 3*x + 6;
}
int main()
{
int t;
double y, l, r;
scanf("%d",&t);
while(t--)
{
scanf("%lf",&y);
if(y<fun(0) || y>fun(100))
{
puts("No solution!");
continue;
}
l = 0;
r = 100;
double mid = (l+r)/2;
while(fabs(fun(mid)-y)>1e-6)
{
if(fun(mid)<y)
l = mid;
else
r = mid;
mid = (l+r)/2;
}
printf("%.4f\n",mid);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: