您的位置:首页 > 产品设计 > UI/UE

poj_1947 Rebuilding Roads(树形dp+背包转移)

2017-02-01 22:01 357 查看
Rebuilding Roads

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 11577 Accepted: 5312
Description
The cows have reconstructed Farmer John's farm, with its N barns (1 <= N <= 150, number 1..N) after the terrible earthquake last May. The cows didn't have time to rebuild any extra roads, so now there is exactly one way to get
from any given barn to any other barn. Thus, the farm transportation system can be represented as a tree.

Farmer John wants to know how much damage another earthquake could do. He wants to know the minimum number of roads whose destruction would isolate a subtree of exactly P (1 <= P <= N) barns from the rest of the barns.
Input
* Line 1: Two integers, N and P

* Lines 2..N: N-1 lines, each with two integers I and J. Node I is node J's parent in the tree of roads.

Output
A single line containing the integer that is the minimum number of roads that need to be destroyed for a subtree of P nodes to be isolated.

Sample Input
11 6
1 2
1 3
1 4
1 5
2 6
2 7
2 8
4 9
4 10
4 11

Sample Output
2

Hint
[A subtree with nodes (1, 2, 3, 6, 7, 8) will become isolated if roads 1-4 and 1-5 are destroyed.] 

设dp[u][pi]为结点u与其子树剩下pi个结点需要删去的边数。
则状态方程:当u到v有边时,dp[u][pi] = min(dp[u][pi-j]+dp[v][j], 即不删去边u-v,0<j<pi
                                                                               dp[u][pi]+1, 即删去边u-v)
当u不是根结点时,dp[u][p]还需加上1,即加上到父节点的边。
记得pi要从p到1枚举,因每条边只能选择删与不删,实际是一个01背包。

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <stack>
#include <bitset>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <algorithm>
#define FOP freopen("data.txt","r",stdin)
#define FOP2 freopen("data1.txt","w",stdout)
#define inf 0x3f3f3f3f
#define maxn 160
#define mod 1000000007
#define PI acos(-1.0)
#define LL long long
using namespace std;

int n, p;
vector<int> G[maxn];
int dp[maxn][maxn]; //dp[i][j]指结点i与其子树 剩下j个结点 需要减少的边数。

void init()
{
for(int i = 0; i <= n; i++) G[i].clear();
}

void addedge(int u, int v)
{
G[u].push_back(v);
}

void dfs(int u)
{
for(int i = 1; i <= n; i++) dp[u][i] = inf;
dp[u][1] = 0;

for(int i = 0; i < G[u].size(); i++)
{
int v = G[u][i];
dfs(v);

int t;
for(int pi = p; pi >= 1; pi--)
{
t = dp[u][pi]+1;
for(int j = 1; j < pi; j++)
t = min(t, dp[u][pi-j]+dp[v][j]);
dp[u][pi] = t;
}
}
}

int main()
{
while(~scanf("%d%d", &n, &p))
{
init();
int u, v;
for(int i = 1; i <= n-1; i++)
{
scanf("%d%d", &u, &v);
addedge(u, v);
}
dfs(1);

int ans = dp[1][p];
for(int i = 2; i <= n; i++) ans = min(ans, dp[i][p]+1); //加上连上父节点的边

printf("%d\n", ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: