您的位置:首页 > 其它

hdu1068【二分图最大独立集】

2017-02-01 17:31 190 查看
Girls and Boys

Time Limit: 20000/10000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 11091 Accepted Submission(s): 5187

Problem Description

the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students

the description of each student, in the following format

student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 …

or

student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.

For each given data set, the program should write to standard output a line containing the result.

Sample Input

7

0: (3) 4 5 6

1: (2) 4 6

2: (0)

3: (0)

4: (2) 0 1

5: (1) 0

6: (2) 0 1

3

0: (2) 1 2

1: (1) 0

2: (1) 0

Sample Output

5

2

题意:一些人之间有关系,求一个最大的集合,使里面的任意两个人都没有关系。

题目分析:最大独立集问题,建立二分图,

最大独立集=n-最大匹配

因为二分图是双向建立的,最大匹配要除以2.

代码:

#include <iostream>
#include <string>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <algorithm>
#include <queue>
#include <map>
#include <sstream>
#define Maxn 100005
using namespace std;
bool edge[500][500];
int  n;
int cx[505], cy[505];
bool vis[505];
int path(int u)
{
int v;
for (v = 0; v < n; v++)
{
if (edge[u][v] && !vis[v])
{
vis[v] = 1;
if (cy[v] == -1 || path(cy[v]))
{
cx[u] = v;
cy[v] = u;
return 1;
}
}
}
return 0;
}
int main()
{
while (cin >> n)
{
memset(cx, -1, sizeof(cx));
memset(cy, -1, sizeof(cy));
memset(edge, 0, sizeof(edge));
int a, b;
for (int i = 0; i < n; i++)
{
scanf("%d: (%d)", &a, &b);
while (b--)
{
scanf("%d", &a);
edge[i][a] = 1;
}
}
int ans = 0;
for (int i = 0; i < n; i++)
{
memset(vis, 0, sizeof(vis));
ans += path(i);
}
printf("%d\n", n - ans / 2 );
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: