您的位置:首页 > 编程语言 > C语言/C++

POJ 1442-Black Box(动态区间第K小-优先队列)

2017-01-30 21:58 507 查看
Black Box

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 12404 Accepted: 5088
Description

Our Black Box represents a primitive database. It can save an integer array and has a special i variable. At the initial moment Black Box is empty and i equals 0. This Black Box processes a sequence of commands (transactions). There are two types of transactions: 

ADD (x): put element x into Black Box; 

GET: increase i by 1 and give an i-minimum out of all integers containing in the Black Box. Keep in mind that i-minimum is a number located at i-th place after Black Box elements sorting by non- descending. 

Let us examine a possible sequence of 11 transactions: 

Example 1 
N Transaction i Black Box contents after transaction Answer

(elements are arranged by non-descending)

1 ADD(3)      0 3

2 GET         1 3                                    3

3 ADD(1)      1 1, 3

4 GET         2 1, 3                                 3

5 ADD(-4)     2 -4, 1, 3

6 ADD(2)      2 -4, 1, 2, 3

7 ADD(8)      2 -4, 1, 2, 3, 8

8 ADD(-1000)  2 -1000, -4, 1, 2, 3, 8

9 GET         3 -1000, -4, 1, 2, 3, 8                1

10 GET        4 -1000, -4, 1, 2, 3, 8                2

11 ADD(2)     4 -1000, -4, 1, 2, 2, 3, 8


It is required to work out an efficient algorithm which treats a given sequence of transactions. The maximum number of ADD and GET transactions: 30000 of each type. 

Let us describe the sequence of transactions by two integer arrays: 

1. A(1), A(2), ..., A(M): a sequence of elements which are being included into Black Box. A values are integers not exceeding 2 000 000 000 by their absolute value, M <= 30000. For the Example we have A=(3, 1, -4, 2, 8, -1000, 2). 

2. u(1), u(2), ..., u(N): a sequence setting a number of elements which are being included into Black Box at the moment of first, second, ... and N-transaction GET. For the Example we have u=(1, 2, 6, 6). 

The Black Box algorithm supposes that natural number sequence u(1), u(2), ..., u(N) is sorted in non-descending order, N <= M and for each p (1 <= p <= N) an inequality p <= u(p) <= M is valid. It follows from the fact that for the p-element of our u sequence
we perform a GET transaction giving p-minimum number from our A(1), A(2), ..., A(u(p)) sequence. 

Input

Input contains (in given order): M, N, A(1), A(2), ..., A(M), u(1), u(2), ..., u(N). All numbers are divided by spaces and (or) carriage return characters.
Output

Write to the output Black Box answers sequence for a given sequence of transactions, one number each line.
Sample Input
7 4
3 1 -4 2 8 -1000 2
1 2 6 6

Sample Output
3
3
1
2

Source

Northeastern Europe 1996

题目意思:

初始情况下,序列中没有任何元素(题中序列第一个元素K表示要GET的第K小元素,不算是序列中的元素)。

ADD(X)是将元素X加入序列中;GET是将K加一后,从序列中取出第K小元素。

给出M个A数组中的元素,表示ADD中的X;N个U数组中的元素,表示当前序列中的元素总个数。

要求出每次GET从序列中取出第K小元素。

解题思路:

q是最大堆的优先队列,存储序列的最小元素到序列的第K小元素;

p是最小堆的优先队列,存储序列的第K+1小元素到序列的最大元素。

压入元素:

遍历U数组,确定当前A数组中要压入队列的元素个数,分情况讨论:

①q中元素不足k个

注意这里不是直接将元素压入q,而是先将元素压入p,再从q里取出最小值压入q。

②q中元素大于等于k个

1’:当前要压入的元素比q的最大值小,q的最大值压入p后出队,当前元素压入q;

2’:当前要压入的元素比q的最大值大(或等于),直接将当前元素压入q。

输出元素:

如果q数组中元素个数小于k,依次将p的队首元素压入q,直到q数组中元素个数等于k。

否则直接输出q的队首元素。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <queue>
#include <algorithm>
const int MAXN=30030;
int a[MAXN],u[MAXN];
using namespace std;
int main()
{
ios::sync_with_stdio(false);
cin.tie(0);
int m,n;
cin>>m>>n;
for(int i=0; i<m; ++i)
cin>>a[i];
for(int i=0; i<n; ++i)
cin>>u[i];
priority_queue<int,vector<int>,greater<int> >p;//最小值优先
priority_queue<int>q;//最大值优先
int k=0,ac=0;//第k小、a数组中的指针
for(int i=0; i<n; ++i)//遍历u数组
{
++k;
int ps=p.size(),qs=q.size();
for(int j=0; j<u[i]-ps-qs; ++j)//向队列中压入的a数组的元素个数
{
if(q.size()<k)//q中元素不足k个
{
//先将元素压入p,再从q里取出最小值压入q
p.push(a[ac]);
q.push(p.top());
p.pop();
++ac;
}
else//q中元素大于k个
{
if(q.top()>a[ac])//当前要压入的元素比q的最大值小
{
//q的最大值压入p后出队,当前元素压入q
p.push(q.top());
q.pop();
q.push(a[ac]);
++ac;
}
else//当前要压入的元素比q的最大值大
{
//直接将当前元素压入q
p.push(a[ac]);
++ac;
}
}
}
if(q.size()<k)//如果q数组中元素个数小于k
{
//依次将p的队首元素压入q,直到q数组中元素个数等于k
int temp=k-q.size();//需要压入q的元素个数
for(int j=0; j<temp; ++j)
{
q.push(p.top());
p.pop();
}
}
cout<<q.top()<<endl;
}
return 0;
}
/*
7 4 3 1 -4 2 8 -1000 2 1 2 6 6
*/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息