您的位置:首页 > 产品设计 > UI/UE

文章标题 POJ 2533 : Longest Ordered Subsequence (DP)

2017-01-29 14:09 561 查看

Longest Ordered Subsequence

A numeric sequence of ai is ordered if a1 < a2 < … < aN. Let the subsequence of the given numeric sequence ( a1, a2, …, aN) be any sequence ( ai1, ai2, …, aiK), where 1 <= i1 < i2 < … < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7

1 7 3 5 9 4 8

Sample Output

4

题意: 给出一串数字,然后求出这串数字上升的序列的最长序列,简称最长上升子序列

分析:用ans【i】表示上升串的第i个数字,然后遍历每一个数字,如果比上升序列的最后一个数字还大,那么就将数字加入,如果小于,那么将这个数字将上升序列中第一个比这个数字大的数字交换。

代码:

#include<iostream>
#include<string>
#include<cstdio>
#include<cstring>
#include<vector>
#include<math.h>
#include<map>
#include<queue>
#include<algorithm>
using namespace std;
const int inf = 0x3f3f3f3f;
int n;
int num[1005];//数字
int ans[1005];//用来保存上升序列
int main ()
{
while (cin>>n){
for (int i=1;i<=n;i++){
cin>>num[i];//输入
}
int cnt=0;
ans[++cnt]=num[1];//一开始为第一数字
for (int i=2;i<=n;i++){//遍历
if (num[i]>ans[cnt]){//如果比最大的数字还大
ans[++cnt]=num[i];//加入
}
else if (num[i]<ans[cnt]){//如果小,那么将序列中的第一个比num【i】的数交换
int place;
//二分查找比num【i】大的第一个数
place=upper_bound (ans,ans+cnt,num[i])-(ans);
if (place<=cnt)ans[place]=num[i];
/*
遍历查找
for (int j=1;j<=cnt;j++){
if (ans[j]>num[i]){
ans[j]=num[i];
break;
}
}
*/
}
}
cout<<cnt<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: