您的位置:首页 > 大数据 > 人工智能

uva 10803 Thunder Mountain

2017-01-25 13:42 429 查看
原题:

Markus is building an army to fight the evil Valhalla Sector, so he needs to move some supplies between several of the nearby towns. The woods are full of robbers and other unfriendly folk, so it’s dangerous to travel far. As Thunder Mountain’s head of security, Lee thinks that it is unsafe to carry supplies for more than 10km without visiting a town. Markus wants to know how far one would need to travel to get from one town to another in the worst case.

Input

The first line of input gives the number of cases, N. N test cases follow. Each one starts with a line containing n (the number of towns, 1 < n < 101). The next n lines will give the xy-locations of each town in km (integers in the range [0,1023]). Assume that the Earth is flat and the whole 1024 × 1024 grid is covered by a forest with roads connecting each pair of towns that are no further than 10km away from each other.

Output

For each test case, output the line ‘Case #x:’, where x is the number of the test case. On the next line, print the maximum distance one has to travel from town A to town B (for some A and B). Round the answer to 4 decimal places. Every answer will obey the formula |ans ∗ 10 4 − ⌊ans ∗ 10 4 ⌋ − 0.5| > 10 −2

If it is impossible to get from some town to some other town, print ‘Send Kurdy’ instead. Put an empty line after each test case.

Sample Input

2

5

0 0

10 0

10 10

13 10

13 14

2

0 0

10 1

Sample Output

Case #1:

25.0000

Case #2:

Send Kurdy

中文:

给你一堆节点坐标,如果两个节点之间的距离超过10那么这两个节点之间被看做不可到达。现在问你给定的这个图是否是连通的,如果不连通,输出Send Kurdy,否则算出这个图中所有节点到其他节点的最短路径,然后找出最短路径中最长的。

#include<bits/stdc++.h>
using namespace std;
struct point
{
double x,y;
};
point points[110];
int n;
double G[110][110];
double dist(const point &a,const point &b)
{
return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}

void floyed()
{
double ans=0;
int ii,jj;
for(int k=1;k<=n;k++)
{
for(int i=1;i<=n;i++)
{
for(int j=1;j<=n;j++)
{
G[i][j]=min(G[i][j],G[i][k]+G[k][j]);
}
}
}
}
int main()
{
ios::sync_with_stdio(false);
int t;
cin>>t;
int k=1;
while(t--)
{
cin>>n;
for(int i=1;i<=n;i++)
cin>>points[i].x>>points[i].y;
memset(G,0,sizeof(G));
for(int i=1;i<=n;i++)
{
for(int j=1;j<=n;j++)
{
double dis=dist(points[i],points[j]);
if(dis<=10)
G[i][j]=dis;
else
G[i][j]=INT_MAX;
}
}
floyed();
double ans=-1;
for(int i=1;i<=n;i++)
{
for(int j=1;j<=n;j++)
ans=max(ans,G[i][j]);
}
if(ans>=INT_MAX)
{
cout<<"Case #"<<k++<<':'<<endl;
cout<<"Send Kurdy"<<endl;
}
else
{
cout<<"Case #"<<k++<<':'<<endl;
cout<<fixed<<setprecision(4)<<ans<<endl;
}
cout<<endl;
}
return 0;
}


解答:

这题说的好隐晦,第一样例怎么算出来的我都想了半天。实际上就是用floyed算出最短路径后,找出这些最短路径当中最长的即可。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: