您的位置:首页 > 其它

UVa120 Stacks of Flap jacks

2017-01-25 00:02 423 查看

Background

Stacks and Queues are often considered the bread and butter of data structures and nd use in architecture,parsing, operating systems, and discrete event simulation. Stacks are alsoimportant in the theory of formal languages.

This problem involves both butter and sustenance in the form of pancakes rather than bread in addition to a nicky server who

ips pancakes according to a unique, but complete set of rules.

The Problem

Given a stack of pancakes, you are to write a program that indicates how the stack can be sorted so that the largest pancake is on the bottom and the smallest pancake is on the top. The size of a pancake is given by the pancake’s diameter. All pancakes in a stack have di erent diameters.

Sorting a stack is done by a sequence of pancake ips”. A ip consists of inserting a spatula between two pancakes in a stack and ipping (reversing) all the pancakes on the spatula (reversing the sub-stack).

A ip is speci ed by giving the position of the pancake on the bottom of the sub-stack to be ipped (relative to the whole stack). The pancake on the bottom of the whole stack has position 1 and the pancake on the top of a stack of n pancakes has position n.

A stack is speci ed by giving the diameter of each pancake in the stack in the order in which the

pancakes appear.

For example, consider the three stacks of pancakes below (in which pancake 8 is the top-most pancake

of the left stack):

8 7 2

4 6 5

6 4 8

7 8 4

5 5 6

2 2 7

The stack on the left can be transformed to the stack in the middle via

ip(3). The middle stack can

be transformed into the right stack via the command

ip(1).

The Input

The input consists of a sequence of stacks of pancakes. Each stack will consist of between 1 and 30

pancakes and each pancake will have an integer diameter between 1 and 100. The input is terminated

by end-of- le. Each stack is given as a single line of input with the top pancake on a stack appearing

rst on a line, the bottom pancake appearing last, and all pancakes separated by a space.

The Output

For each stack of pancakes, the output should echo the original stack on one line, followed by some

sequence of ips that results in the stack of pancakes being sorted so that the largest diameter pancake

is on the bottom and the smallest on top. For each stack the sequence of ips should be terminated by

a 0 (indicating no more

ips necessary). Once a stack is sorted, no more

ips should be made.

Sample Input

1 2 3 4 5

5 4 3 2 1

5 1 2 3 4

Sample Output

1 2 3 4 5

0

5 4 3 2 1

1 0

5 1 2 3 4

1 2 0

题解

这道题要求排序,但是基本操作确是“颠倒一个子序列”,因此我们想到每次把半径最大的煎饼排好,再排小的(此时已排好的煎饼不会受影响)。

代码

#include <cstdio>
#include <cstdlib>
using namespace std;

const int maxn = 40;
int r[maxn], n;

inline bool prepare()
{
char c; bool flag = false;
n = 0;
while(scanf("%d%c", &r[++n], &c) == 2) {
printf("%d%c", r
, c);
flag = true;
if(c == '\n') break;
}
return flag;
}

inline void swap(int &a, int & b)
{
a = a + b; b = a - b; a = a - b;
}

inline void flip(int i)
{
for(int j = 1; j <= i / 2; j++)
swap(r[j], r[i - j + 1]);
}

inline int max_r(int i)
{
int maxr = r[1], maxi = 1;
for(int j = 2; j <= i; j++)
if(maxr < r[j]) {
maxr = r[j]; maxi = j;
}
return maxi;
}

inline bool done()
{
for(int i = 1; i < n; i++)
if(r[i] > r[i + 1]) return false;
return true;
}

int main()
{
freopen("input.in", "r", stdin);
freopen("output.out", "w", std
9a4f
out);
register int i;
while(prepare()) {
for(i = n; i >= 1; i--) {
if(done()) break;
int p = max_r(i); //寻找区间最大值
if(p == i) continue; //最底下的已为最大值
if(p != 1) flip(p), printf("%d ", n - p + 1); //交换的不在顶上
flip(i); printf("%d ", n - i + 1);
}
printf("0\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: