您的位置:首页 > 其它

hdu1003 Max Sum(dp)

2017-01-23 22:41 330 查看
Problem Description

Given a sequence a[1],a[2],a[3]……a
, your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output

For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input

2

5 6 -1 5 4 -7

7 0 6 -1 1 -6 7 -5

Sample Output

Case 1:

14 1 4

Case 2:

7 1 6

#include<cstdio>
#include<iostream>
#include<string.h>
using namespace std;
const int maxn=100000+5;
int dp[maxn];
int l[maxn];
int r[maxn];

int a[maxn];

int main(){
int t;
scanf("%d",&t);
int cas=1;
while(t--){
memset(l,0,sizeof(l));
memset(r,0,sizeof(r));
printf("Case %d:\n",cas++);
int n;
scanf("%d",&n);
for(int i=1;i<=n;i++){
scanf("%d",&a[i]);
dp[i]=a[i];
}
l[1]=1,r[1]=1;
for(int i=2;i<=n;i++){
if(dp[i]<=dp[i-1]+a[i]){
dp[i]=dp[i-1]+a[i];
l[i]=l[i-1];
r[i]=i;
}
else{
l[i]=i,r[i]=i;
}
//printf("dp[%d]=%d, l=%d, r=%d\n",i,dp[i],l[i],r[i]);
}
int ans=dp[1];
int i,j=1;
for(i=2;i<=n;i++){
if(ans<dp[i]){
ans=dp[i];
j=i;
}

}
printf("%d %d %d\n",ans,l[j],r[j]);
if(t)
printf("\n");

}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: