您的位置:首页 > 编程语言 > C语言/C++

PAT甲级1063

2017-01-23 16:07 267 查看


1063. Set Similarity (25)

时间限制

300 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Given two sets of integers, the similarity of the sets is defined to be Nc/Nt*100%, where Nc is the number of distinct common numbers shared by the two sets,
and Nt is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

Input Specification:

Each input file contains one test case. Each case first gives a positive integer N (<=50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (<=104) and followed by M integers in the range
[0, 109]. After the input of sets, a positive integer K (<=2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated
by a space.

Output Specification:

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.
Sample Input:
3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

Sample Output:
50.0%
33.3%


#include<cstdio>
#include<set>
#include<algorithm>
using namespace std;

int main()
{
int n,t,m;
scanf("%d", &n);
set<int> *st = new set<int>[n + 1];
for (int i = 1; i <=n; i++)
{
scanf("%d", &m);
for (int j = 0; j < m; j++)
{
scanf("%d", &t);
st[i].insert(t);
}
}
int k;
scanf("%d", &k); int i1, i2;
//set<int> s;
for (int i = 0; i < k; i++)
{
scanf("%d%d", &i1, &i2);
int size1 = st[i1].size();
int count = 0, total = size1;
/*for (set<int>::iterator it = st[i1].begin(); it != st[i1].end(); it++)
{
s.insert(*(it));
}
for (set<int>::iterator it = st[i2].begin(); it != st[i2].end(); it++)
{
s.insert(*(it));
}
printf("%.1f%%\n", 100 * (size1 + size2 - s.size()) / (double)s.size());
s.clear();
最后一个测试点过不了*/
for (set<int>::iterator it = st[i2].begin(); it != st[i2].end(); it++)
{
if (st[i1].find(*(it)) != st[i1].end())
{
count++;
}
else
total++;
}
printf("%.1f%%\n", 100 * (double)count/total);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息