您的位置:首页 > 其它

Rectangles

2017-01-22 21:48 260 查看

Rectangles

DESCRIPTION

Byteman has a collection of N squares with side 1. How many different rectangles can he form using these squares?

Two rectangles are considered different if none of them can be rotated and moved to obtain the second one. During rectangle construction, Byteman can neither deform the squares nor put any squares upon any other ones.

Input

The first and only line of the standard input contains one integer N (1 <= N <= 10000).

Output

The first and only line of the standard output should contain a single integer equal to the number of different rectangles that Byteman can form using his squares.

Sample input

6

Sample output

8

题解:n个小正方形所能拼成长方形最多的个数

解题:小正方形个数与长和宽能整除

#include <cstdio>
#include <iostream>
#include <cmath>
using namespace std;

int main()
{
int n;
while(scanf("%d",&n)!=EOF)
{
int ans=0;
for(int i=1; i<=n; i++)
{
for(int j=1;j<=(sqrt(i)+0.5);j++)//保留精度
{
if(i%j==0)
ans++;
}
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: