您的位置:首页 > 其它

PAT---1058. A+B in Hogwarts (20)

2017-01-22 21:26 417 查看
题目要求:

If you are a fan of Harry Potter, you would know the world of magic has its own currency system – as Hagrid explained it to Harry, “Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it’s easy enough.” Your job is to write a program to compute A+B where A and B are given in the standard form of “Galleon.Sickle.Knut” (Galleon is an integer in [0, 107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:

3.2.1 10.16.27

Sample Output:

14.1.28

参考代码:

#include <iostream>
#include <stdio.h>
using namespace std;
int main()
{
int galleon = 17*29;
int sickle = 29;
long long a[6] = {0};
scanf("%lld.%lld.%lld",&a[0],&a[1],&a[2]);
scanf("%lld.%lld.%lld",&a[3],&a[4],&a[5]);
long long  expect_money = a[0]*galleon + a[1]*sickle + a[2];
long long own_money = a[3]*galleon + a[4]*sickle + a[5];
long long money = expect_money + own_money;
cout << money/galleon<<"."<<money/sickle%17<<"."<<money%sickle;
return 0;
}


4000
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: