您的位置:首页 > 其它

poj Arbitrage(Floyd||spfa)

2017-01-22 17:03 148 查看
Arbitrage

Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French
franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent. 

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not. 

Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear.
The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency.
Exchanges which do not appear in the table are impossible. 

Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.
Output

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".
Sample Input
3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output
Case 1: Yes
Case 2: No


ps:Floyd算法变形,直接寻找是否存在正权环即可
代码(Floyd):
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<map>
using namespace std;

map<string,int>st;
double d
4000
[50][50];
int n,m;

int main()
{
int casr=1;
while(~scanf("%d",&n),n)
{
int i,j,k;
char s1[50],s2[50];
for(i=1; i<=n; i++)
{
scanf("%s",s1);
st[s1]=i;
d[i][i]=1;
}
scanf("%d",&m);
double x;
for(i=1; i<=m; i++)
{
scanf("%s %lf %s",s1,&x,s2);
d[st[s1]][st[s2]]=x;
}
for(k=1; k<=n; k++)
for(i=1; i<=n; i++)
for(j=1; j<=n; j++)
if(d[i][j]<d[i][k]*d[k][j])
d[i][j]=d[i][k]*d[k][j];
printf("Case %d: ",casr++);
int flag=0;
for(i=1; i<=n; i++)
if(d[i][i]>1)
{
flag=1;
break;
}
if(flag)
printf("Yes\n");
else
printf("No\n");
}
return 0;
}


代码(spfa):
#include<stdio.h>
#include<string.h>

#define maxn 1000+10
struct node
{
int u,v;
double w;
} G[maxn];
int n,m;
double d[maxn];

void Bellman_Ford(int st)
{
memset(d,0,sizeof(d));
d[st]=1;
for(int i=1; i<=n-1; i++)
{
int flag=0;
for(int j=1; j<=m; j++)
{
int u=G[j].u,v=G[j].v;
double w=G[j].w;
if(d[v]<d[u]*w)
{
d[v]=d[u]*w;
flag=1;
}
}
if(!flag)
{
printf("No\n");
return ;
}
}
for(int i=1; i<=m; i++)
{
int u=G[i].u,v=G[i].v;
double w=G[i].w;
if(d[v]<d[u]*w)
{
printf("Yes\n");
return ;
}
}
printf("No\n");
}

int main()
{
int k=1;
while(~scanf("%d",&n),n)
{
char s[33][20];
for(int i=1;i<=n;i++)
scanf("%s",s[i]);
scanf("%d",&m);
char u[20],v[20];
int x,y;
double w;
for(int i=1;i<=m;i++)
{
scanf("%s %lf %s",u,&w,v);
for(int j=1;j<=n;j++)
{
if(!strcmp(u,s[j]))
x=j;
if(!strcmp(v,s[j]))
y=j;
}
G[i].u=x,G[i].v=y,G[i].w=w;
}
printf("Case %d: ",k++);
Bellman_Ford(1);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: