您的位置:首页 > 其它

poj 3280 Cheapest Palindrome

2017-01-20 23:41 260 查看
Cheapest Palindrome

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 9215 Accepted: 4447
Description

Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag's contents are currently a single
string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).

Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is "abcba" would read the same no matter which direction the she walks, a cow with the ID "abcb" can potentially register as two
different IDs ("abcb" and "bcba").

FJ would like to change the cows's ID tags so they read the same no matter which direction the cow walks by. For example, "abcb" can be changed by adding "a" at the end to form "abcba" so that the ID is palindromic (reads the same forwards and backwards).
Some other ways to change the ID to be palindromic are include adding the three letters "bcb" to the begining to yield the ID "bcbabcb" or removing the letter "a" to yield the ID "bcb". One can add or remove characters at any location in the string yielding
a string longer or shorter than the original string.

Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤ cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow's ID tag and the cost of
inserting or deleting each of the alphabet's characters, find the minimum cost to change the ID tag so it satisfies FJ's requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated
costs can be added to a string.

Input

Line 1: Two space-separated integers: N and M 

Line 2: This line contains exactly M characters which constitute the initial ID string 

Lines 3..N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.
Output

Line 1: A single line with a single integer that is the minimum cost to change the given name tag.
Sample Input
3 4
abcb
a 1000 1100
b 350 700
c 200 800

Sample Output
900

Hint

If we insert an "a" on the end to get "abcba", the cost would be 1000. If we delete the "a" on the beginning to get "bcb", the cost would be 1100. If we insert "bcb" at the begining of the string, the cost would be 350 + 200 + 350 = 900, which is the minimum.
Source

USACO 2007 Open Gold


提示

题意:

给出长m(1<=m<=2000)全是小写字母的字符串,且给出添加或删除每个字符的花费,求出使得该字符串变成回文的最小花费。对于添加或删除字符只限于字符串头或尾。

思路:

仔细想想,无论是添加或删除都是一样的,因此取它们两个最小即可。

递推式:

dp[i][j]=min(dp[i-1][j]+cost,dp[i][j+1]+cost)对头、尾操作所需最少花费。

if(ch[i]==ch[j])

{

    dp[i][j]=min(dp[i][j],dp[i-1][j+1]);

}

相等时,到下一状态是否进行操作。

示例程序

Source Code

Problem: 3280		Code Length: 723B
Memory: 16028K		Time: 79MS
Language: GCC		Result: Accepted
#include <stdio.h>
#include <string.h>
int dp[2000][2000];
int min(int x,int y)
{
if(x<y)
{
return x;
}
else
{
return y;
}
}
int main()
{
int n,m,i,j,cost[26],x,y;
char ch[2001],s[2];
memset(dp,0,sizeof(dp));
scanf("%d %d",&n,&m);
scanf("%s",ch);
for(i=1;n>=i;i++)
{
scanf("%s %d %d",s,&x,&y);
cost[s[0]-'a']=min(x,y);
}
for(i=1;m>i;i++)
{
for(j=i-1;j>=0;j--)
{
dp[i][j]=min(dp[i][j+1]+cost[ch[j]-'a'],dp[i-1][j]+cost[ch[i]-'a']);
if(ch[i]==ch[j])
{
dp[i][j]=min(dp[i][j],dp[i-1][j+1]);
}
}
}
printf("%d",dp[m-1][0]);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: